<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8"/>
<meta name="news_keywords" content="contract, copyright, ghostscript, gnu, gpl, license, artifex, hancom">
<meta property="og:title" content="US Court Upholds Enforceability Of GNU GPL As Both A License And A Contract"/>
<meta property="og:description" content="Free software dominates modern computing, from smartphones to supercomputers -- only the desktop remains a stronghold of proprietary code. Most of that free software has the Linux kernel at its heart, and a key element in the success of Linux -- and..."/>
<meta property="og:type" content="article"/>
<meta property="og:url" content="https://www.techdirt.com/articles/20170515/06040337368/us-court-upholds-enforceability-gnu-gpl-as-both-license-contract.shtml"/>
<meta property="og:image" content="https://ii.techdirt.com/s/t/i/td_icon_300.png"/>
<meta property="og:site_name" content="Techdirt."/>
<meta property="fb:admins" content="589029834"/>
<meta property="fb:app_id" content="207400865951050"/>
<meta name="twitter:card" content="summary"/>
<meta name="twitter:site" content="@techdirt"/>
<meta name="twitter:title" content="US Court Upholds Enforceability Of GNU GPL As Both A License And A Contract"/>
<meta name="twitter:description" content="Free software dominates modern computing, from smartphones to supercomputers -- only the desktop remains a stronghold of proprietary..."/>
<meta name="twitter:image" content="https://ii.techdirt.com/s/t/i/td_icon_300.png">
<title>US Court Upholds Enforceability Of GNU GPL As Both A License And A Contract | Techdirt</title>
<link rel="canonical" href="https://www.techdirt.com/articles/20170515/06040337368/us-court-upholds-enforceability-gnu-gpl-as-both-license-contract.shtml"/>
<link href="https://ii.techdirt.com/s/t/styles/styles_layout.css?v=3416-c389" rel="styleSheet" type="text/css"/>
<link href="https://ii.techdirt.com/s/t/styles/styles_format.css?v=3416-c389" rel="styleSheet" type="text/css"/>
<link href="https://ii.techdirt.com/s/t/styles/styles_ic.css?v=3416-c389" rel="styleSheet" type="text/css"/>
<link href="https://ii.techdirt.com/s/t/styles/comment_styles.css?v=3416-c389" rel="styleSheet" type="text/css"/>
<script type="text/javascript" src="https://www.google.com/jsapi?key=ABQIAAAAP1-MNFVAklfwK5qmyUi6NxQZwUsFJbig14JSRSVYVQkoD9a3mRSdvg7cYYJvTKbSxH1uhcSj2BLX-w"></script>
<script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jquery/3.1.0/jquery.min.js"></script><script src="https://ii.techdirt.com/s/t/scripts/techdirt.js?v=3416-c389" type="text/javascript" language="javascript"></script>
<script type="text/javascript" language="javascript">
var sid = '20170515/06040337368';
var base_path = 'https://www.techdirt.com';
</script>
<script src="https://ii.techdirt.com/s/t/scripts/td-jq-cmnt.js?v=3416-c389" type="text/javascript" language="javascript"></script>
<script type="text/javascript">
var iroot = 'https://ii.techdirt.com/s/t/i';
</script>
<script type="text/javascript">var _sf_startpt=(new Date()).getTime()</script> 
<script type="text/javascript">
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
ga('create', 'UA-275652-1', 'auto');
ga('set', 'dimension1', 'anonymous');
ga('set', 'dimension2', 'no');
ga('set', 'dimension3', 'yes');
ga('set', 'dimension4', 'Article');
ga('set', 'dimension5', '1');
ga('send', 'pageview');
ga('send', 'event', 'Article Page', 'View Page', 'https://www.techdirt.com/articles/20170515/06040337368/us-court-upholds-enforceability-gnu-gpl-as-both-license-contract.shtml');
</script>
 
<script type="text/javascript" async src="https://load.instinctiveads.com/i.js"></script>
<script type="text/javascript" src="https://s3.amazonaws.com/widgets.stackcommerce.com/js-deal-feed/0.1/widget.js"></script>
<script type="text/javascript" async="async" src="https://www.googletagservices.com/tag/js/gpt.js"></script>
<script type="text/javascript">
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
</script>
<script type="text/javascript">
googletag.cmd.push(function() {
ga('send', 'event', 'Ads', 'Run DFP Script', 'Load DFP Ads');
});
googletag.cmd.push(function() {
googletag.defineSlot('/54692344/ATF_300x250', [[300, 250], [300, 600]], 'div-gpt-ad-1485380025559-0').addService(googletag.pubads());
googletag.defineSlot('/54692344/BTF_300x250', [300, 250], 'div-gpt-ad-1485380025559-1').addService(googletag.pubads());
googletag.defineSlot('/54692344/BTF_300x250_2', [[300, 250], [300, 600]], 'div-gpt-ad-1485380025559-2').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.enableServices();
});
</script>
<meta property="fb:pages" content="6623059427"/>
<style type="text/css">div#blog,div#tdci,div#greenhouse,div#subnav,div#navigation{width:1000px;}div#contents{width:980px;}div#maincolumn{width:700px;}div.storysep{width:685px;}</style>
</head>
<body>
<div id="top">
 
<div id="navigation">
<div id="toptabs">
<ul class="toptabs">
<li style="margin-left:20px;border:0;">
<form action="/search-g.php" method="get">
<input type="text" size="16" name="q" onclick="javascript:clearfield(this,'Search Techdirt');" onblur="javascript:unclearfield(this,'Search Techdirt');" value="Search Techdirt" style="display:inline-block;width:140px;"/>
<input value="Search" type="submit"/>
</form>
</li>
</ul>
</div><div id="hdr_middle" style="clear:both;">
<a href="/"><img class="hdricon" src="https://ii.techdirt.com/s/t/i/td-icon-40x40.png" alt="Techdirt" height="40" width="40" border="0"/></a><a href="/"><img class="navimg" src="https://ii.techdirt.com/s/t/i/logos/td-techdirt.png" alt="Techdirt" height="40" border="0"/></a></div>
<div id="tabs">
<ul class="untabs">
<li><a href="/signin.php?nexturl=https%3A%2F%2Fwww.techdirt.com%2Farticles%2F20170515%2F06040337368%2Fus-court-upholds-enforceability-gnu-gpl-as-both-license-contract.shtml">Sign In</a></li>
<li><a href="/register.php">Register</a></li>
<li><a href="/preferences.php">Preferences</a></li>
</ul>
<ul class="tabs">
<li class="selected"><a href="/">Techdirt</a></li>
<li><a href="/blog/wireless/">Wireless News</a></li>
<li><a href="/blog/innovation/">Innovation</a></li>
<li><a href="/blog/casestudies/">Case Studies</a></li>
<li><a href="/blog/startups/">Startups</a></li>
<li><a href="/blog/netneutrality/">Net Neutrality</a></li>
<li class="spacer">&nbsp;</li>
<li class="tab_deals"><a href="https://deals.techdirt.com">Techdirt Deals!</a></li>
</ul>
</div></div>  
</div>  
 <div id="subnav">
<ul class="subtabs">
<li><a href="/blog/">Main</a></li>
<li><a href="/submitstory.php">Submit a Story</a></li>
<li><a title="Techdirt RSS" href="/techdirt_rss.xml" rel="nofollow"><img src="https://ii.techdirt.com/s/t/i/share/rss11.png" alt="rss" style="margin:0;padding:0;"/> RSS</a></li>
</ul></div><div id="blog">
<div id="maincolumn_wrap">
<div id="maincolumn">
<div class="maincolumn_head">
</div>  
<div id="maincol_top">
<div style="background:#dddddd;padding:6px 7px;">
<a href="https://www.techdirt.com/blog/podcast/"><img src="https://ii.techdirt.com/s/t/i/podcast-title-small.png" style="display:block;float:left;margin-right:12px;"/></a>
<div style="width:556px;float:left;"><iframe width="100%" height="20" scrolling="no" frameborder="no" src="https://w.soundcloud.com/player/?url=https%3A//api.soundcloud.com/tracks/322939002&amp;color=2665ad&amp;inverse=false&amp;auto_play=false&amp;show_user=true"></iframe></div><div style="clear:both;"></div>
</div></div><div class="storynav" style="margin-top:5px;">
<div class="storynav_next">
&nbsp;</div>
<div class="storynav_prev">
&lt;&lt;&nbsp;<a onclick="ga('send', 'event', 'Story Nav (Article)', 'Click Link', 'Previous Techdirt Post');" title="previous Techdirt post: Appeals Court Pretty Sure DOJ Use-Of-Force Guidelines Don&#39;t Violate Police Officers&#39; 2nd And 4th Amendment Rights" href="/articles/20170509/18094537330/appeals-court-pretty-sure-doj-use-of-force-guidelines-dont-violate-police-officers-2nd-4th-amendment-rights.shtml" style="color:#777777;">Appeals Court Pretty Sure DOJ Use-Of-Force...</a></div>
<div class="storynav_icon">
&nbsp;<img src="https://ii.techdirt.com/s/t/i/td13x13.png" width="13" height="13" alt="tdicon"/>&nbsp;
</div>
</div>
<br clear="all"/>
 
<div class="storyblock">
<div class="details">
<a href="/search.php?tid=Copyright&search=Search"><span class="topic_icon" style="background-position: -400px 0px;"></span></a>
<p><a href="/search.php?tid=Copyright&search=Search">Copyright</a></p>
<p>by
<a href="/user/glynmoody">Glyn Moody</a></p><p class="storydate">Wed, May 17th 2017 6:28pm</p><br/>
<p class="filed">
Filed Under:<br/>
<b><a href="/blog/?tag=contract"> contract</a>, <a href="/blog/?tag=copyright">copyright</a>, <a href="/blog/?tag=ghostscript">ghostscript</a>, <a href="/blog/?tag=gnu">gnu</a>, <a href="/blog/?tag=gpl">gpl</a>, <a href="/blog/?tag=license">license</a></b>
</p>
<p class="filed">
Companies:<br/>
<b><a href="/blog/?company=artifex"> artifex</a>, <a href="/blog/?company=hancom">hancom</a></b>
</p>
<br/>
<p><a class="permalink" href="https://www.techdirt.com/articles/20170515/06040337368/us-court-upholds-enforceability-gnu-gpl-as-both-license-contract.shtml">Permalink.</a><br><a class="permalink" href="https://tdrt.io/gdq">Short link.</a></p>
</div>
<div class="storywrap">
<div class="story">
<h1 class="posttitle">US Court Upholds Enforceability Of GNU GPL As Both A License <i>And</i> A Contract</h1><h3>from the <i>but-might-that-prove-a-mixed-blessing?</i> dept</h3><div class="postbody">
<p>
Free software dominates modern computing, from <a href="https://qz.com/826672/android-goog-just-hit-a-record-88-market-share-of-all-smartphones/">smartphones</a> to <a href="https://www.top500.org/statistics/sublist/">supercomputers</a> -- only the desktop remains a stronghold of proprietary code. Most of that free software has the Linux kernel at its heart, and a key element in the success of Linux -- and of thousands of other coding projects -- is the GNU General Public License. Although the <a href="https://www.gnu.org/licenses/old-licenses/gpl-1.0.en.html">first version</a> of the GNU GPL was released by Richard Stallman back in 1989, and <a href="https://www.gnu.org/licenses/gpl.html">version 3</a> was issued in 2007, there have been surprisingly few court cases examining it and other open source licenses, and whether they are legally watertight.
</p>
<p>
A key case is Jacobsen v. Katzer from 2008. As a detailed Groklaw post at the time explained, the US appeals court held that <a href="http://www.groklaw.net/article.php?story=2008081313212422">open source license conditions are enforceable as a copyright condition</a>. Now we have another important judgment, Artifex v. Hancom, that clarifies further the legal basis of open source licenses. It concerns the well-known Ghostscript interpreter for the PostScript language, written originally by <a href="https://www.artifex.com/about-us/">L. Peter Deutsch</a>, and sold by the company he founded, <a href="https://www.artifex.com/">Artifex Software</a>. Artifex was a pioneer in adopting a dual-licensing approach for Ghostscript. That is, you could either use the software under the GNU GPL, or you could avoid <a href="https://www.gnu.org/licenses/copyleft.en.html">copyleft's redistribution requirements</a> by taking out a conventional proprietary license.
</p>
<p>
Hancom is a South Korean company that produces Hangul, word-processing software that is primarily used in South Korea as an alternative to Microsoft Word. Artifex says that Hancom incorporated Ghostscript into its Hangul software, but neither sought a proprietary license, nor complied with the terms of the GPL by releasing the source code for the application that incorporated Ghostscript. As a result, Artifex took legal action, alleging copyright infringement and breach of contract. Hancom asked the court to dismiss Artifex's complaint on several grounds, but they were all denied. The most significant ruling is on Hancom's claim that the GNU GPL was not a contract. In her order, embedded below, Judge Jacqueline Scott Corley wrote:
</p>
<blockquote><em>
<p>
The GNU GPL, which is attached to the complaint, provides that the Ghostscript user agrees to its terms if the user does not obtain a commercial license. Plaintiff alleges that Defendant used Ghostscript, did not obtain a commercial license, and represented publicly that its use of Ghostscript was licensed under the GNU GPL. These allegations sufficiently plead the existence of a contract.
</p>
</em></blockquote>
<p>
That's an important new ruling. The judge also affirmed a result of the Jacobsen v. Katzer case, that even though code released under the GPL is available free of charge, damages could still be awarded because:
</p>
<blockquote><em>
<p>
there is harm which flows from a party's failure to comply with open source licensing.
</p>
</em></blockquote>
<p>
A <a href="http://www.lexology.com/library/detail.aspx?g=98d5ec53-ce49-40fc-a2e4-7a1c84a2aa46">useful analysis of the judge's order on the Lexology blog</a> explains the pros and cons of bringing cases under copyright and contract law:
</p>
<blockquote><em>
<p>
Generally, copyright claims may afford plaintiffs more damages and stronger remedies than contract claims. However, contract claims may help a plaintiff pursue a violator's worldwide conduct in a way that jurisdictional limits on copyright claims might not allow. Breach of contract claims may also be able to address reputational harm and other indirect non-economic benefits that a plaintiff might derive from enforcing open source license conditions. A breach of contract claim might also, in certain instances, allow for specific performance of open source obligations.
</p>
</em></blockquote>
<p>
However, the fact that Artifex may now proceed, drawing on both copyright and contract law, raises the important question of how those interact. Mike wrote about this back in <a href="https://www.techdirt.com/articles/20100707/04163310101.shtml">2010</a>, and pointed to a <a href="https://copycense.com/2009/08/31/is_creative_commons_good_for_copyright/">longer discussion of the legal questions involved</a>. The decision by the District Court for the Northern District of California to allow Artifex to move forward with its case is certainly an important confirmation of the legal solidity of open source licensing. But it also brings with it important questions about the role of <a href="http://www.groklaw.net/article.php?story=20031214210634851">contracts in the world of free software</a>.
</p>
<p>
Follow me @glynmoody on <a href="https://twitter.com/glynmoody">Twitter</a> or <a href="https://identi.ca/glynmoody">identi.ca</a>, and +glynmoody on <a href="https://plus.google.com/+glynmoody">Google+</a>
</p><div class="centered">
<div id="DV-viewer-3720615-Gov-Uscourts-Cand-305835-32-0" class="DC-embed DC-embed-document DV-container"></div>
<p>
<script src="//assets.documentcloud.org/viewer/loader.js"></script>
<script>
 DV.load("https://www.documentcloud.org/documents/3720615-Gov-Uscourts-Cand-305835-32-0.js", {
 width: 560,
 height: 550,
 sidebar: false,
 container: "#DV-viewer-3720615-Gov-Uscourts-Cand-305835-32-0"
 });
</script>
<noscript>
<a href="https://assets.documentcloud.org/documents/3720615/Gov-Uscourts-Cand-305835-32-0.pdf">Gov Uscourts Cand 305835 32 0 (PDF)</a>
<br/>
<a href="https://assets.documentcloud.org/documents/3720615/Gov-Uscourts-Cand-305835-32-0.txt">Gov Uscourts Cand 305835 32 0 (Text)</a>
</noscript>
</p>
</div>
</div>
</div>  
</div>  
<div class="storyfooter">
<a name="share"></a><div class="storytools">
<div class="sharetools" style="float:right;">
<a onclick="ga('send', 'event', 'Share Bar (Article)', 'Share', 'Email Story');" title="Email this" href="https://www.techdirt.com/emailthis.php?et_sid=20170515/06040337368" target="_top" rel="nofollow" class="emailthis_button"><span class="share_button share_email"></span></a>
<a onclick="ga('send', 'event', 'Share Bar (Article)', 'Share', 'Twitter');" class="share_pop" title="Tweet" target="_blank" href="https://twitter.com/share?url=https%3A%2F%2Ftdrt.io%2Fgdq&text=US+Court+Upholds+Enforceability+Of+GNU+GPL+As+Both+A+License+And+A+Contract&via=Techdirt"><span class="share_button share_twitter"></span></a>
<a onclick="ga('send', 'event', 'Share Bar (Article)', 'Share', 'Google +1');" class="share_pop" title="Google +1" target="_blank" href="https://plus.google.com/share?url=https%3A%2F%2Fwww.techdirt.com%2Farticles%2F20170515%2F06040337368%2Fus-court-upholds-enforceability-gnu-gpl-as-both-license-contract.shtml"><span class="share_button share_plusone"></span></a>
<a onclick="ga('send', 'event', 'Share Bar (Article)', 'Share', 'Facebook Share');" class="share_pop" title="Share on Facebook" target="_blank" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.techdirt.com%2Farticles%2F20170515%2F06040337368%2Fus-court-upholds-enforceability-gnu-gpl-as-both-license-contract.shtml&t=US+Court+Upholds+Enforceability+Of+GNU+GPL+As+Both+A+License+And+A+Contract"><span class="share_button share_facebook"></span></a>
<a onclick="ga('send', 'event', 'Share Bar (Article)', 'Share', 'Reddit');" class="share_pop" title="Reddit This!" target="_blank" href="http://reddit.com/submit?url=https%3A%2F%2Fwww.techdirt.com%2Farticles%2F20170515%2F06040337368%2Fus-court-upholds-enforceability-gnu-gpl-as-both-license-contract.shtml&title=US+Court+Upholds+Enforceability+Of+GNU+GPL+As+Both+A+License+And+A+Contract"><span class="share_button share_reddit"></span></a>
<a onclick="ga('send', 'event', 'Share Bar (Article)', 'Share', 'LinkedIn');" class="share_pop" title="Share on LinkedIn" target="blank" href="http://www.linkedin.com/shareArticle?mini=true&ro=false&title=US+Court+Upholds+Enforceability+Of+GNU+GPL+As+Both+A+License+And+A+Contract&url=https%3A%2F%2Fwww.techdirt.com%2Farticles%2F20170515%2F06040337368%2Fus-court-upholds-enforceability-gnu-gpl-as-both-license-contract.shtml"><span class="share_button share_linkedin"></span></a>
</div>
<div class="storylinks"><a href="https://www.techdirt.com/articles/20170515/06040337368/us-court-upholds-enforceability-gnu-gpl-as-both-license-contract.shtml#comments" onclick="ga('send', 'event', 'Article (Index)', 'Click Link', 'Article 1 Comments');">3 Comments</a> | <a href="https://www.techdirt.com/articles/20170515/06040337368/us-court-upholds-enforceability-gnu-gpl-as-both-license-contract.shtml#addyourcomment" onclick="ga('send', 'event', 'Article (Index)', 'Click Link', 'Article 1 Leave Comment');">Leave a Comment</a></div>
</div>
<div id="post_footer">
<iframe src="https://isupportjournalism.com/donate.html" width="580" height="250" style="border:none;"></iframe></div></div>  
<br clear="both"/>
 
<div class="relposts">
<div class="maincolumn_head">If you liked this post, you may also be interested in...</div>
<div class="maincolmod">
<ul>
<li><a onClick="ga('send', 'event', 'Related Posts (Article)', 'Click Link', 'Related Post 1');" href="/articles/20170516/11302737383/texas-court-orders-sports-streaming-sites-to-be-blocked-anticipation-piracy.shtml">Texas Court Orders Sports Streaming Sites To Be Blocked In <b>Anticipation</b> Of Piracy</a></li>
<li><a onClick="ga('send', 'event', 'Related Posts (Article)', 'Click Link', 'Related Post 2');" href="/articles/20170512/07150837347/makers-payday-2-donating-dlc-profits-to-help-2-youtubers-fight-copyright-lawsuit.shtml">Makers Of Payday 2 Donating DLC Profits To Help 2 YouTubers Fight Copyright Lawsuit</a></li>
<li><a onClick="ga('send', 'event', 'Related Posts (Article)', 'Click Link', 'Related Post 3');" href="/articles/20170516/06083537378/new-netflix-drm-blocks-rooted-phone-owners-downloading-netflix-app.shtml">New Netflix DRM Blocks Rooted Phone Owners From Downloading The Netflix App</a></li>
<li><a onClick="ga('send', 'event', 'Related Posts (Article)', 'Click Link', 'Related Post 4');" href="/articles/20170511/14313937343/nier-automata-modder-includes-piracy-checks-mod-causing-uproar-should-it.shtml">Nier Automata Modder Includes Piracy Checks In Mod, Causing An Uproar, But Should It?</a></li>
<li><a onClick="ga('send', 'event', 'Related Posts (Article)', 'Click Link', 'Related Post 5');" href="/articles/20081104/1621182738.shtml">When We Said We Were In Favor Of Open Source Voting, This Isn't What We Meant</a></li>
</ul>
</div>
</div>
 </div>  <a name="comments"></a>
<div class="comments">
<h2 style="margin-bottom:10px;">Reader Comments</h2>
<p style="float:right;position:relative;z-index:1;">Subscribe: <a href="/comment_rss.php?sid=20170515/06040337368" rel="nofollow">RSS</a></p>
<p style="float:left;">View by: <a href="/articles/20170515/06040337368/us-court-upholds-enforceability-gnu-gpl-as-both-license-contract.shtml?threaded=false&sp=1#comments" onclick="javascript:setPreference('tdCommentsThreaded', 0, true);return false;">Time</a> | <a href="/articles/20170515/06040337368/us-court-upholds-enforceability-gnu-gpl-as-both-license-contract.shtml?threaded=true&sp=1#comments" onclick="javascript:setPreference('tdCommentsThreaded', 1, true);return false;">Thread</a></p>
<br style="clear:both"/>
<ul class="comments">
<li id="c38" class="cmt">
<div id="cc38">
<div class="comment-buttons" id="rc_38"><a rel="nofollow" href="/bounce/rate-comment.php?rc=ins_20170515/06040337368_38" value="0" id="ins_20170515/06040337368_38" class="rate_comment insightful-button"></a><a rel="nofollow" href="/bounce/rate-comment.php?rc=fun_20170515/06040337368_38" value="0" id="fun_20170515/06040337368_38" class="rate_comment funny-button"></a><a href="https://rtb.techdirt.com/products/credits/" class="fw-button off" target="_blank"></a><a href="https://rtb.techdirt.com/products/credits/" class="lw-button off" target="_blank"></a><a rel="nofollow" href="/bounce/rate-comment.php?rc=rpt_20170515/06040337368_38" value="0" id="rpt_20170515/06040337368_38" class="rate_comment report-button"></a></div>
<div class="commentname"><img src="https://www.gravatar.com/avatar/deaad247e46afc56452693955cf3cd4c?d=identicon&s=20" width="20" height="20" alt="identicon"/><div style="display:inline;"><b>Anonymous Coward</b>, <i>17 May 2017 @ 7:32pm</i></div><br style="clear:both;"/></div>
<div class="cbody">I hope PJ still has her red dress. Oh I miss Groklaw so much.<br/>PJ, if you read this, I wish you all the best!</div><p class="cmt_ops">[&nbsp;<a class="cmtrp" href="/articles/20170515/06040337368/us-court-upholds-enforceability-gnu-gpl-as-both-license-contract.shtml?cid=38#addyourcomment" cid="38" subject="" cid="38" title="Reply to this comment..." id="cmmt_link_38" rel="nofollow">reply to this</a>&nbsp;|&nbsp;<a href="/articles/20170515/06040337368/us-court-upholds-enforceability-gnu-gpl-as-both-license-contract.shtml#c38">link to this</a>&nbsp;|&nbsp;<a href="/articles/20170515/06040337368/us-court-upholds-enforceability-gnu-gpl-as-both-license-contract.shtml?threaded=false#c38">view in chronology</a>&nbsp;]
</p>
</div>
</li>
<li id="c41" class="cmt">
<div id="cc41">
<div class="comment-buttons" id="rc_41"><a rel="nofollow" href="/bounce/rate-comment.php?rc=ins_20170515/06040337368_41" value="0" id="ins_20170515/06040337368_41" class="rate_comment insightful-button"></a><a rel="nofollow" href="/bounce/rate-comment.php?rc=fun_20170515/06040337368_41" value="0" id="fun_20170515/06040337368_41" class="rate_comment funny-button"></a><a href="https://rtb.techdirt.com/products/credits/" class="fw-button off" target="_blank"></a><a href="https://rtb.techdirt.com/products/credits/" class="lw-button off" target="_blank"></a><a rel="nofollow" href="/bounce/rate-comment.php?rc=rpt_20170515/06040337368_41" value="0" id="rpt_20170515/06040337368_41" class="rate_comment report-button"></a></div>
<div class="commentname"><img class="cmnt-icon" src="https://ii.techdirt.com/s/t/i/user/81/u8120_30x0.jpg" width="30" alt="icon"/><div style="display:inline;"><b>Kal Zekdor</b> (<a href="/user/kalzekdor">profile</a>), <i>17 May 2017 @ 7:35pm</i></div><br style="clear:both;"/></div>
<h3 class="commentsubject">Meh, GPL.</h3><div class="cbody">I'll take an MIT license project over a GPL or derivative any day of the week.</div><p class="cmt_ops">[&nbsp;<a class="cmtrp" href="/articles/20170515/06040337368/us-court-upholds-enforceability-gnu-gpl-as-both-license-contract.shtml?cid=41#addyourcomment" cid="41" subject="Meh, GPL." cid="41" title="Reply to this comment..." id="cmmt_link_41" rel="nofollow">reply to this</a>&nbsp;|&nbsp;<a href="/articles/20170515/06040337368/us-court-upholds-enforceability-gnu-gpl-as-both-license-contract.shtml#c41">link to this</a>&nbsp;|&nbsp;<a href="/articles/20170515/06040337368/us-court-upholds-enforceability-gnu-gpl-as-both-license-contract.shtml?threaded=false#c41">view in chronology</a>&nbsp;]
</p>
</div>
</li>
<li id="c49" class="cmt">
<div id="cc49">
<div class="comment-buttons" id="rc_49"><a rel="nofollow" href="/bounce/rate-comment.php?rc=ins_20170515/06040337368_49" value="0" id="ins_20170515/06040337368_49" class="rate_comment insightful-button"></a><a rel="nofollow" href="/bounce/rate-comment.php?rc=fun_20170515/06040337368_49" value="0" id="fun_20170515/06040337368_49" class="rate_comment funny-button"></a><a href="https://rtb.techdirt.com/products/credits/" class="fw-button off" target="_blank"></a><a href="https://rtb.techdirt.com/products/credits/" class="lw-button off" target="_blank"></a><a rel="nofollow" href="/bounce/rate-comment.php?rc=rpt_20170515/06040337368_49" value="0" id="rpt_20170515/06040337368_49" class="rate_comment report-button"></a></div>
<div class="commentname"><img src="https://www.gravatar.com/avatar/513b174c563084cc6583757b829697a7?d=identicon&s=20" width="20" height="20" alt="identicon"/><div style="display:inline;"><b>Anonymous Coward</b>, <i>17 May 2017 @ 7:46pm</i></div><br style="clear:both;"/></div>
<div class="cbody">Stallman was right.</div><p class="cmt_ops">[&nbsp;<a class="cmtrp" href="/articles/20170515/06040337368/us-court-upholds-enforceability-gnu-gpl-as-both-license-contract.shtml?cid=49#addyourcomment" cid="49" subject="" cid="49" title="Reply to this comment..." id="cmmt_link_49" rel="nofollow">reply to this</a>&nbsp;|&nbsp;<a href="/articles/20170515/06040337368/us-court-upholds-enforceability-gnu-gpl-as-both-license-contract.shtml#c49">link to this</a>&nbsp;|&nbsp;<a href="/articles/20170515/06040337368/us-court-upholds-enforceability-gnu-gpl-as-both-license-contract.shtml?threaded=false#c49">view in chronology</a>&nbsp;]
</p>
</div>
</li>
</ul>
<br/><a name="addyourcomment"></a>
<h3>Add Your Comment</h3>
<div class="commentform">
<form name="commentform" action="/comment_process.php" method="post">
<input type="hidden" name="nospam" value="yes"/>
<input type="hidden" name="sid" value="20170515/06040337368"/><input type="hidden" name="replycid" value="0"/>
<table width="100%">
<tr><td colspan="2">Have a Techdirt Account? <a href="/signin.php?nexturl=https%3A%2F%2Fwww.techdirt.com%2Farticles%2F20170515%2F06040337368%2Fus-court-upholds-enforceability-gnu-gpl-as-both-license-contract.shtml"><b>Sign in now</b></a>. Want one? <a href="/register.php?nexturl=https%3A%2F%2Fwww.techdirt.com%2Farticles%2F20170515%2F06040337368%2Fus-court-upholds-enforceability-gnu-gpl-as-both-license-contract.shtml"><b>Register here</b></a></td></tr>
<tr><td><label for="name">Name</label></td><td><input class="8" id="name" type="text" name="postername" size="50" value=""/></td></tr>
<tr>
<td><label for="email">Email</label></td>
<td><input class="8" id="email" type="text" name="posteremail" size="50" value=""/>
<input class="8" type="checkbox" name="emailsignup" value="yes"/> Get <a href="https://listserv.techdirt.com/cgi-bin/dada/mail.cgi/list/techdirt/">Techdirt&rsquo;s Daily Email</a></td>
</tr>
<tr><td><label for="url">URL</label></td><td><input class="8" id="url" type="text" name="posterurl" size="50" maxlength="255" value=""/></td></tr>
<tr><td><label for="subject">Subject</label></td><td><input class="8" id="subject" type="text" name="postersubj" size="50" maxlength="255" value=""/></td></tr>
<tr>
<td valign="top"><label for="comment">Comment</label></td>
<td><textarea class="8" name="postercomment" rows="10" cols="60" style="display:none;">this is for spambots, do not use this</textarea>
<textarea class="8" id="comment" name="p1stercomment" rows="10" cols="60"></textarea></td>
</tr>
<tr>
<td valign="top"><label for="options">Options</label></td>
<td><input class="8" type="checkbox" name="mrkdwn" title="Convert markdown to HTML"/> Use <a href="http://commonmark.org/help/" target="_blank">markdown</a> for basic formatting. HTML is no longer supported.</td>
</tr>
<tr>
<td>&nbsp;</td>
<td><input class="8" type="checkbox" name="cookie"/> Save me a cookie</td></tr>
<tr><td></td><td><input class="8" type="submit" name="mode" value="Submit"/> <input class="8" type="submit" name="mode" value="Preview"/></td></tr>
</table>
</form></div>  
 
<div id="cmmt_form" style="display:none;">
<a href="#" class="cmmt_close">Close</a>
<form name="commentform" action="/comment_process.php" method="post">
<input type="hidden" name="nospam" value="yes"/>
<input type="hidden" name="sid" value="20170515/06040337368"/><input type="hidden" name="replycid" id="replycid" value="0"/>
<table width="100%">
<tr><td colspan="2">Have a Techdirt Account? <a href="/signin.php?nexturl=https%3A%2F%2Fwww.techdirt.com%2Farticles%2F20170515%2F06040337368%2Fus-court-upholds-enforceability-gnu-gpl-as-both-license-contract.shtml"><b>Sign in now</b></a>. Want one? <a href="/register.php?nexturl=https%3A%2F%2Fwww.techdirt.com%2Farticles%2F20170515%2F06040337368%2Fus-court-upholds-enforceability-gnu-gpl-as-both-license-contract.shtml"><b>Register here</b></a></td></tr>
<tr><td><label for="name">Name</label></td><td><input id="name" type="text" name="postername" size="50" value=""/></td></tr>
<tr>
<td><label for="email">Email</label></td>
<td><input id="email" type="text" name="posteremail" size="50" value=""/>
<input type="checkbox" name="emailsignup" value="yes"/> Get <a href="https://listserv.techdirt.com/cgi-bin/dada/mail.cgi/list/techdirt/">Techdirt&rsquo;s Daily Email</a></td>
</tr>
<tr><td><label for="url">URL</label></td><td><input id="url" type="text" name="posterurl" size="50" maxlength="255" value=""/></td></tr>
<tr><td><label for="subject">Subject</label></td><td><input id="replysubject" type="text" name="postersubj" size="50" maxlength="255" value=""/></td></tr>
<tr>
<td valign="top"><label for="comment">Comment</label></td>
<td><textarea name="postercomment" rows="10" cols="60" style="display:none;">this is for spambots, do not use this</textarea>
<textarea id="comment" name="p1stercomment" rows="10" cols="60"></textarea></td>
</tr>
<tr>
<td valign="top"><label for="options">Options</label></td>
<td><input type="checkbox" name="mrkdwn" title="Convert markdown to HTML"/> Use <a href="http://commonmark.org/help/" target="_blank">markdown</a> for basic formatting. HTML is no longer supported.</td>
</tr>
<tr>
<td>&nbsp;</td>
<td><input type="checkbox" name="cookie"/> Save me a cookie</td></tr>
<tr><td></td><td><input type="submit" name="mode" value="Submit"/> <input type="submit" name="mode" value="Preview"/></td></tr>
</table>
</form></div>  
</div>
<script type="text/javascript">
var fcnt = 0;
var icnt = 0;
</script>
 <div class="storynav" style="margin-top:5px;">
<div class="storynav_next">
&nbsp;</div>
<div class="storynav_prev">
&lt;&lt;&nbsp;<a onclick="ga('send', 'event', 'Story Nav (Article)', 'Click Link', 'Previous Techdirt Post');" title="previous Techdirt post: Appeals Court Pretty Sure DOJ Use-Of-Force Guidelines Don&#39;t Violate Police Officers&#39; 2nd And 4th Amendment Rights" href="/articles/20170509/18094537330/appeals-court-pretty-sure-doj-use-of-force-guidelines-dont-violate-police-officers-2nd-4th-amendment-rights.shtml" style="color:#777777;">Appeals Court Pretty Sure DOJ Use-Of-Force...</a></div>
<div class="storynav_icon">
&nbsp;<img src="https://ii.techdirt.com/s/t/i/td13x13.png" width="13" height="13" alt="tdicon"/>&nbsp;
</div>
</div>
</div>  
</div>  
<div id="rightcolumn">
<script type="text/javascript">
var etpg = 'Article';
</script>
<style type="text/css">.FlattrButton{margin-top:2px;}</style>
<div class="rightcolumn_head">Follow Techdirt</div>
<div class="rightcolumn_main" style="text-align:center;">
<div id="subscribe">
<a title="Flattr us" href="https://flattr.com/thing/99823/Techdirt-" target="_blank" onclick="ga('send', 'event', 'Follow Techdirt (Article)', 'Click', 'Follow - Flattr');" class="follow flattr"></a>
<a title="Follow us on Twitter" href="https://twitter.com/techdirt" target="_blank" onclick="ga('send', 'event', 'Follow Techdirt (Article)', 'Click', 'Follow - Twitter');" class="follow twitter"></a>
<a title="Become a fan on Facebook" href="https://www.facebook.com/techdirt" target="_blank" onclick="ga('send', 'event', 'Follow Techdirt (Article)', 'Click', 'Follow - Facebook');" class="follow facebook"></a>
<a title="Subscribe to our Newsletter" id="email_sub_tgl" href="https://news.techdirt.com/cgi-bin/dada/mail.cgi/list/tddaily" class="follow email"></a>
<a title="Subscribe to our RSS Feed" href="/techdirt_rss.xml" rel="nofollow" class="follow rss" onclick="(function(btn){var z=document.createElement('script');document.subtomeBtn=btn;z.src='https://www.subtome.com/load.js';document.body.appendChild(z);})(this);return false;" data-subtome-feeds="https://www.techdirt.com/techdirt_rss.xml"></a>
<a title="Subscribe to our Podcast" href="/podcast.xml" rel="nofollow" class="follow podcast"></a>
<div id="email_sub_form" class="hidden">
<h3>Techdirt Daily Newsletter</h3>
<form action="https://news.techdirt.com/cgi-bin/dada/mail.cgi" method="post" style="margin-top:3px;">
<input name="f" value="subscribe" type="hidden"/>
<input onclick="javascript:clearfield(this,'Enter Your Email Address');" name="email" value="Enter Your Email Address" size="25" maxlength="1024" type="text"/><input value="Subscribe" type="submit"/>
<input name="list" value="tddaily" type="hidden"/>
</form>
</div>
</div>
</div><div class="rightcolumn_head">Special Affiliate Offer</div>
<div id="rtcol_1">
<a href="https://www.privateinternetaccess.com/pages/techdirt-offer" target="_blank" title="Free Techdirt Crystal Ball With VPN From Private Internet Access"><img src="https://ii.techdirt.com/s/t/images/promo/rc-pia-vpn.png" title="Free Techdirt Crystal Ball With VPN From Private Internet Access"/></a><br/>
</div><div class="rightcolumn_head">Advertisement</div>
<div id="rtcol_2" class="ad">
 
<div id="div-gpt-ad-1485380025559-0" style="max-height:600px; width:300px;">
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1485380025559-0'); });
</script>
</div></div>
<div style="margin:0;padding:3px 5px 5px 5px;text-align:center;"><a href="/badad.php" style="font-style:italic;font-size:11px;" target="_blank" onclick="window.open('/badad.php', 'Report a bad ad on Techdirt', 'width=600,height=600,location=0,menubar=0,scrollbars=0,status=0,titlebar=1,toolbar=0', false);return(false);" rel="nofollow">Report this ad</a>&nbsp;&nbsp;|&nbsp;&nbsp;<a href="/preferences.php" style="font-style:italic;font-size:11px;">Hide Techdirt ads</a></div><style type="text/css"></style>
<div class="rightcolumn_head">Essential Reading</div>
<div class="rightcolumn_main">
<div id="recreading">
<h4>Hot Topics</h4>
<ul>
<li class="ranked">
<a onclick="ga('send', 'event', 'Hot Topics (Article)', 'Click Link', '#1 Hot Topic');" class="toppost-value" style="background-color:#ffaa33;border:#ffaa33;" href="/articles/20170515/06040337368/us-court-upholds-enforceability-gnu-gpl-as-both-license-contract.shtml" title="Rank">5.2</a>
<a onclick="ga('send', 'event', 'Hot Topics (Article)', 'Click Link', '#1 Hot Topic');" class="toppost-title" href="/articles/20170515/06040337368/us-court-upholds-enforceability-gnu-gpl-as-both-license-contract.shtml" title="US Court Upholds Enforceability Of GNU GPL As Both A License <i>And</i> A Contract">US Court Upholds Enforceability Of GNU GPL As Both A License <i>And</i> A Contract</a>
</li>
<li class="ranked">
<a onclick="ga('send', 'event', 'Hot Topics (Article)', 'Click Link', '#2 Hot Topic');" class="toppost-value" style="background-color:#ffbb33;border:#ffbb33;" href="/articles/20170516/06570237379/time-fcc-to-actually-listen-vast-majority-fcc-commenters-support-net-neutrality.shtml" title="Rank">5.2</a>
<a onclick="ga('send', 'event', 'Hot Topics (Article)', 'Click Link', '#2 Hot Topic');" class="toppost-title" href="/articles/20170516/06570237379/time-fcc-to-actually-listen-vast-majority-fcc-commenters-support-net-neutrality.shtml" title="It&#39;s Time For The FCC To Actually Listen: The Vast Majority Of FCC Commenters Support Net Neutrality">It&#39;s Time For The FCC To Actually Listen: The Vast Majority Of FCC Commenters Support Net Neutrality</a>
</li>
<li class="ranked">
<a onclick="ga('send', 'event', 'Hot Topics (Article)', 'Click Link', '#3 Hot Topic');" class="toppost-value" style="background-color:#ffcc33;border:#ffcc33;" href="/articles/20170513/10394837355/fcc-spent-last-week-trying-to-make-net-neutrality-supporters-seem-unreasonable-racist-unhinged.shtml" title="Rank">5.1</a>
<a onclick="ga('send', 'event', 'Hot Topics (Article)', 'Click Link', '#3 Hot Topic');" class="toppost-title" href="/articles/20170513/10394837355/fcc-spent-last-week-trying-to-make-net-neutrality-supporters-seem-unreasonable-racist-unhinged.shtml" title="The FCC Spent Last Week Trying To Make Net Neutrality Supporters Seem Unreasonable, Racist & Unhinged">The FCC Spent Last Week Trying To Make Net Neutrality Supporters Seem Unreasonable, Racist & Unhinged</a>
</li>
</ul>
<hr/>
<h4>New To Techdirt?</h4>
<p>Explore some core concepts:</p>
<ul>
<li><a href="/articles/20070125/004949/step-one-to-embracing-lack-scarcity-recognize-what-market-youre-really.shtml" onclick="ga('send', 'event', 'Editors Spotlight (Article)', 'Click Link', 'Spotlight 1');">Step One To Embracing A Lack Of Scarcity: Recognize What Market You're Really In</a></li>
<li><a href="/articles/20070301/005837/economic-explanation-why-drm-cannot-open-up-new-business-model-opportunities.shtml" onclick="ga('send', 'event', 'Editors Spotlight (Article)', 'Click Link', 'Spotlight 2');">An Economic Explanation For Why DRM Cannot Open Up New Business Model Opportunities</a></li>
<li><a href="/articles/20091119/1634117011/future-music-business-models-those-who-are-already-there.shtml" onclick="ga('send', 'event', 'Editors Spotlight (Article)', 'Click Link', 'Spotlight 3');">The Future Of Music Business Models (And Those Who Are Already There)</a></li>
</ul>
<p style="text-align:right;"><a href="/blog/?tag=techdirt+feature">read all &#187;</a></p>
</div>
</div><div class="rightcolumn_head">Techdirt Deals</div>
<div id="rtcol_3" class="ad">
 
<div data-sc-widget data-publisher-id="93" data-layout="vertical" data-categories="88,90,91" data-show-see-all="false" data-title-size="24" data-items-per-page="1" data-col-count="1"></div></div>
<div style="margin:0;padding:3px 5px 5px 5px;text-align:center;"><a href="/badad.php" style="font-style:italic;font-size:11px;" target="_blank" onclick="window.open('/badad.php', 'Report a bad ad on Techdirt', 'width=600,height=600,location=0,menubar=0,scrollbars=0,status=0,titlebar=1,toolbar=0', false);return(false);" rel="nofollow">Report this ad</a>&nbsp;&nbsp;|&nbsp;&nbsp;<a href="/preferences.php" style="font-style:italic;font-size:11px;">Hide Techdirt ads</a></div><link href="https://ii.techdirt.com/s/t/styles/styles_tdichat.css?v=3416-c389" rel="styleSheet" type="text/css"/>
<div class="rightcolumn_head">Techdirt Insider Chat</div>
<div id="chatwrapper">
<br/><div id="chatbox">
<div id="chatmsgs">
&nbsp;
</div>
</div>
<div id="chatfooter">
<p style="text-align:center;padding:10px;padding-top:0;"><a href="https://rtb.techdirt.com/products/watercooler/" class="greenbutton">Join the Insider Chat</a></p>
</div>
</div>
<script type="text/javascript">
var iroot = 'https://ii.techdirt.com/s/t/i';
var chat_standalone = false;
var chat_id = '3d43d546';
</script>
<script src="https://ii.techdirt.com/s/t/scripts/td-jq-ichat.js?v=3416-c389" type="text/javascript" language="javascript"></script>
<script type="text/javascript">
$j(document).ready(function() { loadChatPreview(); });
</script>
<div class="rightcolumn_head">Advertisement</div>
<div id="rtcol_5" class="ad">
 
<div id="div-gpt-ad-1485380025559-1" style="height:250px;width:300px;">
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1485380025559-1'); });
</script>
</div></div>
<div style="margin:0;padding:3px 5px 5px 5px;text-align:center;"><a href="/badad.php" style="font-style:italic;font-size:11px;" target="_blank" onclick="window.open('/badad.php', 'Report a bad ad on Techdirt', 'width=600,height=600,location=0,menubar=0,scrollbars=0,status=0,titlebar=1,toolbar=0', false);return(false);" rel="nofollow">Report this ad</a>&nbsp;&nbsp;|&nbsp;&nbsp;<a href="/preferences.php" style="font-style:italic;font-size:11px;">Hide Techdirt ads</a></div><div class="rightcolumn_head">Recent Stories</div>
<div class="rightcolumn_main">
<table>
<tr><td colspan="2"><h2 class="olderstuff"><a href="/blog/?d=17&m=5&y=2017" onclick="ga('send', 'event', 'Recent Stories (Article)', 'Click Link', 'Wednesday Link');">Wednesday</a></h2></td></tr><tr><td class="olderstuff">18:28</td>
<td class="olderstuff"><a href="/articles/20170515/06040337368/us-court-upholds-enforceability-gnu-gpl-as-both-license-contract.shtml" onclick="ga('send', 'event', 'Recent Stories (Article)', 'Click Link', 'Article Link 1');">US Court Upholds Enforceability Of GNU GPL As Both A License <i>And</i> A Contract</a> (3)</td></tr><tr><td class="olderstuff">15:23</td>
<td class="olderstuff"><a href="/articles/20170509/18094537330/appeals-court-pretty-sure-doj-use-of-force-guidelines-dont-violate-police-officers-2nd-4th-amendment-rights.shtml" onclick="ga('send', 'event', 'Recent Stories (Article)', 'Click Link', 'Article Link 2');">Appeals Court Pretty Sure DOJ Use-Of-Force Guidelines Don&#39;t Violate Police Officers&#39; 2nd And 4th Amendment Rights</a> (9)</td></tr><tr><td class="olderstuff">13:20</td>
<td class="olderstuff"><a href="/articles/20170513/20274537360/magical-cop-detects-drugs-better-than-blood-tests-continues-to-lock-innocent-people-up.shtml" onclick="ga('send', 'event', 'Recent Stories (Article)', 'Click Link', 'Article Link 3');">Magical Cop Detects Drugs Better Than Blood Tests; Continues To Lock Innocent People Up</a> (25)</td></tr><tr><td class="olderstuff">11:47</td>
<td class="olderstuff"><a href="/articles/20170516/11302737383/texas-court-orders-sports-streaming-sites-to-be-blocked-anticipation-piracy.shtml" onclick="ga('send', 'event', 'Recent Stories (Article)', 'Click Link', 'Article Link 4');">Texas Court Orders Sports Streaming Sites To Be Blocked In <b>Anticipation</b> Of Piracy</a> (22)</td></tr><tr><td class="olderstuff">10:42</td>
<td class="olderstuff"><a href="/articles/20170517/09320337392/das-office-facing-multiple-lawsuits-related-to-use-fake-subpoenas-to-intimidate-witnesses.shtml" onclick="ga('send', 'event', 'Recent Stories (Article)', 'Click Link', 'Article Link 5');">DA&#39;s Office Facing Multiple Lawsuits Related To Its Use Of Fake Subpoenas To Intimidate Witnesses</a> (8)</td></tr><tr><td class="olderstuff">10:37</td>
<td class="olderstuff"><a href="/articles/20170517/09200437391/daily-deal-disconnect-premium-subscription.shtml" onclick="ga('send', 'event', 'Recent Stories (Article)', 'Click Link', 'Article Link 6');">Daily Deal: Disconnect Premium Subscription</a> (0)</td></tr><tr><td class="olderstuff">09:23</td>
<td class="olderstuff"><a href="/articles/20170516/15162337387/well-duh-facebooks-system-to-stop-fake-news-isnt-working-because-facebook-isnt-problem.shtml" onclick="ga('send', 'event', 'Recent Stories (Article)', 'Click Link', 'Article Link 7');">Well, Duh: Facebook&#39;s System To Stop &#39;Fake News&#39; Isn&#39;t Working -- Because Facebook Isn&#39;t The Problem</a> (39)</td></tr><tr><td class="olderstuff">06:22</td>
<td class="olderstuff"><a href="/articles/20170516/06570237379/time-fcc-to-actually-listen-vast-majority-fcc-commenters-support-net-neutrality.shtml" onclick="ga('send', 'event', 'Recent Stories (Article)', 'Click Link', 'Article Link 8');">It&#39;s Time For The FCC To Actually Listen: The Vast Majority Of FCC Commenters Support Net Neutrality</a> (87)</td></tr><tr><td class="olderstuff">03:16</td>
<td class="olderstuff"><a href="/articles/20170514/10071637362/inspector-generals-report-shows-section-702-isnt-only-thing-being-abused-nsa.shtml" onclick="ga('send', 'event', 'Recent Stories (Article)', 'Click Link', 'Article Link 9');">Inspector General&#39;s Report Shows Section 702 Isn&#39;t The Only Thing Being Abused By The NSA</a> (6)</td></tr><tr><td colspan="2"><h2 class="olderstuff"><a href="/blog/?d=16&m=5&y=2017" onclick="ga('send', 'event', 'Recent Stories (Article)', 'Click Link', 'Tuesday Link');">Tuesday</a></h2></td></tr><tr><td class="olderstuff">18:03</td>
<td class="olderstuff"><a href="/articles/20170512/07150837347/makers-payday-2-donating-dlc-profits-to-help-2-youtubers-fight-copyright-lawsuit.shtml" onclick="ga('send', 'event', 'Recent Stories (Article)', 'Click Link', 'Article Link 10');">Makers Of Payday 2 Donating DLC Profits To Help 2 YouTubers Fight Copyright Lawsuit</a> (19)</td></tr></table>
<h5><a href="/search.php?start=10&edition=techdirt&search=Search" onclick="ga('send', 'event', 'Recent Stories (Article)', 'Click Link', 'More Link');">More</a>&nbsp;<img alt="arrow" src="https://ii.techdirt.com/s/t/i/widget_arrow.gif" width="14" height="14" hspace="0" vspace="0" border="0"/></h5>
</div><div class="rightcolumn_head">Advertisement</div>
<div id="rtcol_6" class="ad">
 
<script type="text/javascript" language="javascript">   amzn_assoc_ad_type = "contextual";   amzn_assoc_tracking_id = "td_banner-20";   amzn_assoc_marketplace = "amazon";   amzn_assoc_region = "US";   amzn_assoc_placement = "X53E4NV3FMYCADJR";   amzn_assoc_linkid = "X53E4NV3FMYCADJR";
  amzn_assoc_emphasize_categories = "";
  amzn_assoc_fallback_products = "";
  amzn_assoc_width = "300";
  amzn_assoc_height = "250";
</script>
<script type="text/javascript" language="javascript" src="//z-na.amazon-adsystem.com/widgets/q?ServiceVersion=20070822&Operation=GetScript&ID=OneJS&WS=1&MarketPlace=US&source=ac"></script>
</div>
<div style="margin:0;padding:3px 5px 5px 5px;text-align:center;"><a href="/badad.php" style="font-style:italic;font-size:11px;" target="_blank" onclick="window.open('/badad.php', 'Report a bad ad on Techdirt', 'width=600,height=600,location=0,menubar=0,scrollbars=0,status=0,titlebar=1,toolbar=0', false);return(false);" rel="nofollow">Report this ad</a>&nbsp;&nbsp;|&nbsp;&nbsp;<a href="/preferences.php" style="font-style:italic;font-size:11px;">Hide Techdirt ads</a></div></div>  
</div>  
<div id="bottom">
<div id="pagefoot">
<div class="ftrpanel">
<a href=""><img src="https://ii.techdirt.com/s/t/i/td_logov140.png"/></a>
</div>
<div class="ftrpanel">
<h1>Tools &amp; Services</h1>
<a href="https://www.twitter.com/techdirt/">Twitter</a><br/>
<a href="https://www.facebook.com/techdirt">Facebook</a><br/>
<a href="/techdirt_rss.xml">RSS</a><br/>
<a href="/podcast.xml">Podcast</a><br/>
<a href="/?_format=lite">Techdirt for Mobile</a><br/>
<a href="/research.php">Research &amp; Reports</a><br/>
</div>
<div class="ftrpanel">
<h1>Company</h1>
<a href="/about.php">About Us</a><br/>
<a href="/adpolicies.php">Advertising Policies</a><br/>
<a href="/privacy.php">Privacy</a><br/>
</div>
<div class="ftrpanel">
<h1>Contact</h1>
<a href="/contact.php">Help &amp; Feedback</a><br/>
<a href="/mediakit">Media Kit</a><br/>
<a href="/advertise.php">Sponsor/Advertise</a><br/>
<a href="/submitstory.php">Submit a Story</a><br/>
</div>
<div class="ftrpanel">
<h1>More</h1>
<a href="http://copia.is">Copia Institute</a><br/>
<a href="https://www.insightcommunity.com/">Insight Community</a><br/>
<a href="https://www.insightcommunity.com/step2/">Step2</a><br/>
<a href="https://rtb.techdirt.com/">Insider Shop</a><br/>
</div>
<br style="clear:both;"/><br/>
<div style="text-align:center;">
Brought to you by <a href="http://www.floor64.com/">Floor64</a>
</div>
</div>
<br style="clear:both;"/>
</div>
<div id="et_popup">
<a href="#" class="et_close">Close</a>
<p>Email This</p>
<div id="email_this">
<p style="color:#000000;">This feature is only available to registered users. <a href="/register.php">Register</a> or <a href="/signin.php">sign in</a> to use it.</p></div></div>
<script type="text/javascript" src="//platform.twitter.com/widgets.js"></script>
<script type="text/javascript">
var _sf_async_config={};
/** CONFIGURATION START **/
_sf_async_config.uid = 22794;
_sf_async_config.domain = "techdirt.com";
_sf_async_config.path = "/articles/20170515/06040337368/us-court-upholds-enforceability-gnu-gpl-as-both-license-contract.shtml";/** CONFIGURATION END **/
(function(){
function loadChartbeat() {
window._sf_endpt=(new Date()).getTime();
var e = document.createElement('script');
e.setAttribute('language', 'javascript');
e.setAttribute('type', 'text/javascript');
e.setAttribute('src',
(("https:" == document.location.protocol) ? "https://a248.e.akamai.net/chartbeat.download.akamai.com/102508/" : "http://static.chartbeat.com/") +
"js/chartbeat.js");
document.body.appendChild(e);
}
var oldonload = window.onload;
window.onload = (typeof window.onload != 'function') ?
loadChartbeat : function() { oldonload(); loadChartbeat(); };
})();
</script>
</body>
</html>