<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<meta id="tdviewport" name="viewport" content="width=device-width, initial-scale=1.0">
<meta name="news_keywords" content="history, look back">
<meta property="og:title" content="This Week In Techdirt History: May 16th - 22nd" />
<meta property="og:description" content="Five Years Ago   This week in 2016, we were digging deeper into the Oracle/Google fight over the Java API and the challenges therein. Comcast was trying to claim that it wasn&#039;t &#039;feasible&#039; to deliver TV to third-party set top boxes, a..." />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.techdirt.com/articles/20210522/11233746846/this-week-techdirt-history-may-16th-22nd.shtml" />
<meta property="og:image" content="https://ii.techdirt.com/s/t/i/td_icon_300.png" />
<meta property="og:site_name" content="Techdirt." />
<meta property="fb:admins" content="589029834" />
<meta property="fb:app_id" content="207400865951050" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:site" content="@techdirt" />
<meta name="twitter:title" content="This Week In Techdirt History: May 16th - 22nd" />
<meta name="twitter:description" content="Five Years Ago   This week in 2016, we were digging deeper into the Oracle/Google fight over the Java API and the challenges therein..." />
<meta name="twitter:image" content="https://ii.techdirt.com/s/t/i/td_icon_300.png">
<title>This Week In Techdirt History: May 16th - 22nd | Techdirt</title>
<link rel="canonical" type="text/html" href="https://www.techdirt.com/articles/20210522/11233746846/this-week-techdirt-history-may-16th-22nd.shtml" />
<link rel="shortlink" type="text/html" href="https://tdrt.io/ish" />
<link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="/comment_rss.php?sid=20210522/11233746846">
<link rel="stylesheet" href="https://use.fontawesome.com/releases/v5.0.13/css/all.css" integrity="sha384-DNOHZ68U8hZfKXOrtjWvjxusGo9WQnrNx2sqG0tfsghAvtVlRW3tvkXWZh58N9jp" crossorigin="anonymous">
<link rel="styleSheet" type="text/css" href="https://ii.techdirt.com/s/t/styles/techdirt.css?v=3721-c395" />
<link rel="styleSheet" type="text/css" href="https://ii.techdirt.com/s/t/styles/comment_styles.css?v=3721-c395" />
<script src="https://cdnjs.cloudflare.com/ajax/libs/jquery/3.5.1/jquery.min.js" integrity="sha512-bLT0Qm9VnAYZDflyKcBaQ2gg0hSYNQrJ8RilYldYQ1FxQYoCLtUjuuRuZo+fjqhx/qtq/1itJ0C2ejDxltZVFg==" crossorigin="anonymous"></script><script src="https://ii.techdirt.com/s/t/scripts/techdirt.js?v=3721-c395" type="text/javascript" language="javascript"></script>
<script type="text/javascript" language="javascript">
var sid = '20210522/11233746846';
var base_path = 'https://www.techdirt.com';
</script>
<script src="https://ii.techdirt.com/s/t/scripts/td-jq-cmnt.js?v=3721-c395" type="text/javascript" language="javascript"></script>
<link href="https://fonts.googleapis.com/css?family=Raleway:400,600,600i,800" rel="stylesheet">
<script type="text/javascript">
var iroot = 'https://ii.techdirt.com/s/t/i';
</script>
<script type="text/javascript">var _sf_startpt=(new Date()).getTime()</script><script type="text/javascript" src="https://s3.amazonaws.com/widgets.stackcommerce.com/js-deal-feed/0.1/widget.js"></script>
<link href="https://ii.techdirt.com/s/t/styles/greenhouse.css" rel="styleSheet" type="text/css" />
<meta name="monetization" content="$ilp.uphold.com/Jzw3EAY4mnYZ">
<script type="text/javascript">
  var _paq = window._paq = window._paq || [];
  _paq.push(['trackPageView']);
  _paq.push(['enableLinkTracking']);
  (function() {
    var u="//tomo.techdirt.com/matomo/";
    _paq.push(['setTrackerUrl', u+'matomo.php']);
    _paq.push(['setSiteId', '1']);
    var d=document, g=d.createElement('script'), s=d.getElementsByTagName('script')[0];
    g.type='text/javascript'; g.async=true; g.src=u+'matomo.js'; s.parentNode.insertBefore(g,s);
  })();
</script>
<script async defer data-domain="techdirt.com" src="https://tics.techdirt.com/js/index.js"></script>
</head>
<body class="edition-techdirt">
<div id="top">
<div id="header">
<div id="hdr_search">
<form action="/search-g.php" method="get">
<input class="searchq" type="text" size="16" name="q" placeholder="Search Techdirt" /><button class="icon"><i class="fa fa-search" style="margin:auto"></i></button>
</form>
</div>
<div id="hdr_logo">
<a href="/"><img class="hdr_title" src="https://ii.techdirt.com/s/t/i/logos/techdirt.svg" alt="Techdirt." border="0" /></a><br /></div>
<div id="hdr_nav">
<div id="hdr_nav_user">
<input type="checkbox" id="user-toggle">
<label for="user-toggle"><i class="fas fa-user" style="padding:5px;"></i></label>
<ul class="user_menu">
<li><a href="/signin.php?nexturl=https%3A%2F%2Fwww.techdirt.com%2Farticles%2F20210522%2F11233746846%2Fthis-week-techdirt-history-may-16th-22nd.shtml">Sign In</a></li>
<li><a href="/register.php">Register</a></li>
<li><a href="/preferences.php">Preferences</a></li>
</ul>
</div>
<div id="hdr_nav_tabs">
<input type="checkbox" id="tabs-toggle">
<label for="tabs-toggle">Techdirt <i class="fas fa-bars" style="color:#eeeeee"></i></label>
<ul class="tabs_menu">
<li id="edition-tab-techdirt" class="tab_techdirt selected"><a href="/">Techdirt</a></li>
<li id="edition-tab-greenhouse" class="tab_greenhouse"><a href="/blog/greenhouse/">Greenhouse</a></li>
<li id="edition-tab-covid" class="tab_covid"><a href="/blog/covid/">Tech & COVID</a></li>
<li id="edition-tab-freespeech" class="tab_freespeech"><a href="/blog/freespeech/">Free Speech</a></li>
<li class="spacer">&nbsp;</li>
<li class="tab_deals"><a href="https://deals.techdirt.com">Deals</a></li>
<li class="tab_jobs"><a href="https://jobs.techdirt.com">Jobs</a></li>
<li class="tab_support"><a href="/pages/support.php">Support Techdirt</a></li>
</ul>
</div>
</div></div>
</div>
<div id="middle">
<div id="maincol-wrap">
<div id="maincolumn">
<div class="maincolumn_head">
</div> 
<div id="maincol_top">
<div style="background:#dddddd;padding:6px 7px;">
<a href="https://www.techdirt.com/blog/podcast/"><img src="https://ii.techdirt.com/s/t/i/podcast-title-small.png" style="display:block;float:left;margin-right:12px;" /></a>
<div style="width:calc(100% - 130px);max-width:556px;float:left;"><iframe width="100%" height="20" scrolling="no" frameborder="no" src="https://w.soundcloud.com/player/?url=https%3A//api.soundcloud.com/tracks/1051081630&amp;color=2665ad&amp;inverse=false&amp;auto_play=false&amp;show_user=true"></iframe></div><div style="clear:both;"></div>
</div></div><div class="storynav techdirt" style="margin-top:5px;">
<div class="storynav-prev">
<a title="previous Techdirt post: Makers Of &#39;Peaky Blinders&#39; Show Fail To Get Injunction Against Distillery For &#39;Peaky Blinders&#39; Whiskey" href="/articles/20210521/09172546838/makers-peaky-blinders-show-fail-to-get-injunction-against-distillery-peaky-blinders-whiskey.shtml" style="color:#777777;">Makers Of &#39;Peaky Blinders&#39; Show Fail To Get Injunction Against Distillery For &#39;Peaky Blinders&#39; Whiskey</a></div><div class="storynav-next nolink">
&nbsp;</div>
</div>
<br clear="all" />

<div id="p75537" class="storyblock edition-techdirt">
<div class="storywrap">
<div class="story">
<div class="postbody">
<h1 class="posttitle">This Week In Techdirt History: May 16th - 22nd</h1><div class="details">
<a href="/search.php?tid=techdirt&search=Search"><span class="topic_icon" style="background-position: 0px -510px;"></span></a>
<p><a href="/search.php?tid=techdirt&search=Search">Techdirt</a></p>
</div>
<h3>from the <i>memory-lane</i> dept</h3><div class="byline"><span class="pub_date">Sat, May 22nd 2021 12:00pm</span> &mdash;
<a href="/user/leigh">Leigh Beadon</a></div>
<p>
<b>Five Years Ago</b>
</p>
<p>
This week in 2016, we were digging deeper into the <a href="https://www.techdirt.com/articles/20160516/02161034449/how-javas-inherent-verboseness-may-mess-up-fair-use-apis.shtml">Oracle/Google fight over the Java API</a> and the challenges therein. Comcast was trying to claim that it wasn't 'feasible' to <a href="https://www.techdirt.com/articles/20160513/08191234437/comcast-now-trying-to-claim-that-delivering-just-tv-to-third-party-set-top-boxes-not-feasible.shtml">deliver TV to third-party set top boxes</a>, a cable lobbying group was saying that <a href="https://www.techdirt.com/articles/20160511/09580034405/cable-lobbying-group-claims-more-competition-would-hurt-consumers.shtml">more competition would hurt consumers</a>, and a former FCC boss turned cable lobbyist was complaining that the industry was being <a href="https://www.techdirt.com/articles/20160516/10464234452/former-fcc-boss-turned-top-cable-lobbyist-says-cable-industry-being-unfairly-attacked-no-evidence-consumer-harm.shtml">unfairly attacked</a>. Meanwhile, the story of the CIA Torture Report was getting <a href="https://www.techdirt.com/articles/20160516/11213834453/cia-inspector-general-claims-it-accidentally-deleted-cia-torture-report-after-being-asked-to-retain-it.shtml">even stranger</a>, and Senators Wyden and Paul introduced a bill to <a href="https://www.techdirt.com/articles/20160519/10200734487/senators-wyden-paul-introduce-smh-bill-to-stop-massive-expansion-govt-computer-hacking.shtml">stop the expansion of government hacking</a>.
</p>
<p>
<b>Ten Years Ago</b>
</p>
<p>
This week in 2011, we looked closer at the <a href="https://www.techdirt.com/articles/20110516/01484814277/protect-ip-act-is-about-old-media-industry-going-to-war-with-internet.shtml">awful PROTECT IP act</a>, while Google noted the <a href="https://www.techdirt.com/articles/20110518/11311114322/google-points-out-that-protect-ip-would-be-disastrous-precedent-free-speech.shtml">assault on free speech</a> it represented &mdash; an attitude its defenders labelled as <a href="https://www.techdirt.com/articles/20110520/13252214358/being-concerned-with-free-speech-implications-protect-ip-does-not-mean-you-think-youre-above-law.shtml">thinking you're above the law</a>. A Supreme Court ruling took <a href="https://www.techdirt.com/articles/20110517/12313814301/4th-amendment-what-4th-amendment-supremes-say-police-can-create-conditions-to-enter-home-without-warrant.shtml">a huge chunk out of the 4th Amendment</a>, while the <em>Indiana</em> Supreme Court took <a href="https://www.techdirt.com/articles/20110518/17015914326/what-4th-amendment-indiana-sheriff-says-random-warrantless-house-to-house-searches-are-okay.shtml">an <em>even bigger</em> chunk out of it</a>. And it really wasn't a good week for said amendment in general, with <a href="https://www.techdirt.com/articles/20110517/22252614309/riaa-calls-4th-amendment-passe-pushes-warrantless-searches.shtml">the RIAA calling for warrantless searches</a> and Congress <a href="https://www.techdirt.com/articles/20110519/13502414343/congress-just-sold-you-out-leadership-plans-to-extend-patriot-act-four-years-with-no-concessions.shtml">extending the Patriot Act with <em>no</em> concessions</a>.
</p>
<p>
<b>Fifteen Years Ago</b>
</p>
<p>
This week in 2006, we wrote about how amazing <a href="https://www.techdirt.com/articles/20060515/0226221.shtml">an online searchable database of scanned books</a> could be, and how it was already helping <a href="https://www.techdirt.com/articles/20060516/1044229.shtml">bring attention to commercially neglected works</a>. MLB was trying to find a backdoor way to <a href="https://www.techdirt.com/articles/20060516/0251256.shtml">control game data</a>, astroturf continued to grow in <a href="https://www.techdirt.com/articles/20060516/1326227.shtml">the net neutrality debate</a>, and a Canadian politician gave a rare inside look at <a href="https://www.techdirt.com/articles/20060517/1121220.shtml">the RIAA's lobbying/fearmongering tactics</a>. We got a couple important court rulings too, with the Supreme Court noting that <a href="https://www.techdirt.com/articles/20060515/118257.shtml">injunctions don't always make sense in patent cases</a>, and an appeals court highlighting why <a href="https://www.techdirt.com/articles/20060519/035207.shtml">making a profit doesn't disqualify something from fair use exceptions to copyright</a>.
</p><div id="post_end">
<div id="post_end_plea_promo" name="post_end_plea"><img class="promo_close" src="https://ii.techdirt.com/s/t/i/topclose.png" alt="Hide this" title="Hide This" /><style>
div#post_end_plea_promo {background-color:#fefecb;margin:10px 0;padding:5px;}
</style>
<div style="color:#444;font-family:'Georgia','Times',serif;font-size:110%;font-style:italic;line-height:1.5;padding:20px;"><p>Thank you for reading this Techdirt post. With so many things competing for everyone’s attention these days, we really appreciate you giving us your time. We work hard every day to put quality content out there for our community.</p>
<p>Techdirt is one of the few remaining truly independent media outlets. We do not have a giant corporation behind us, and we rely heavily on our community to support us, in an age when advertisers are increasingly uninterested in sponsoring small, independent sites &mdash; especially a site like ours that is unwilling to pull punches in its reporting and analysis.</p>
<p>While other websites have resorted to paywalls, registration requirements, and increasingly annoying/intrusive advertising, we have always kept Techdirt open and available to anyone. But in order to continue doing so, <a href="https://www.techdirt.com/pages/support.php" style="font-weight:bold">we need your support</a>. We offer a variety of ways for our readers to support us, from direct donations to special subscriptions and cool merchandise &mdash; and every little bit helps. Thank you.<br></p>
<p style="margin-left:70%;padding:0;">&ndash;The Techdirt Team</p>
</div>
</div></div><p class="filed">Filed Under: <a href="/blog/?tag=history">history</a>, <a href="/blog/?tag=look+back">look back</a></p></div>
</div>
</div> 
<div class="storyfooter">
<a name="share"></a><div class="storytools">
<div class="sharetools" style="float:right;">
<a class="share_pop" title="Short Link - right-click to copy" target="_blank" href="https://tdrt.io/ish"><span class="share_button share_link"></span></a>
<a class="share_pop" title="Email this" target="_blank" href="https://www.techdirt.com/emailthis.php?et_url=https://www.techdirt.com/articles/20210522/11233746846/this-week-techdirt-history-may-16th-22nd.shtml"><span class="share_button share_email"></span></a>
<a class="share_pop" title="Tweet" target="_blank" href="https://twitter.com/share?url=https%3A%2F%2Ftdrt.io%2Fish&text=This+Week+In+Techdirt+History%3A+May+16th+-+22nd&via=Techdirt"><span class="share_button share_twitter"></span></a>
<a class="share_pop" title="Share on Facebook" target="_blank" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.techdirt.com%2Farticles%2F20210522%2F11233746846%2Fthis-week-techdirt-history-may-16th-22nd.shtml&t=This+Week+In+Techdirt+History%3A+May+16th+-+22nd"><span class="share_button share_facebook"></span></a>
<a class="share_pop" title="Reddit This!" target="_blank" href="https://reddit.com/submit?url=https%3A%2F%2Fwww.techdirt.com%2Farticles%2F20210522%2F11233746846%2Fthis-week-techdirt-history-may-16th-22nd.shtml&title=This+Week+In+Techdirt+History%3A+May+16th+-+22nd"><span class="share_button share_reddit"></span></a>
<a class="share_pop" title="Share on LinkedIn" target="_blank" href="https://www.linkedin.com/shareArticle?mini=true&ro=false&title=This+Week+In+Techdirt+History%3A+May+16th+-+22nd&url=https%3A%2F%2Fwww.techdirt.com%2Farticles%2F20210522%2F11233746846%2Fthis-week-techdirt-history-may-16th-22nd.shtml"><span class="share_button share_linkedin"></span></a>
</div>
<div class="storylinks"><a href="https://www.techdirt.com/articles/20210522/11233746846/this-week-techdirt-history-may-16th-22nd.shtml#addyourcomment">Leave a Comment</a></div>
</div>
<div id="post_footer">
<a href="https://techdirt.threadless.com/accessories/face-mask/premium" target="_blank" title="Face Masks by Techdirt on Threadless"><img src="https://ii.techdirt.com/s/t/i/gear/masks-big-3.png" style="display:block;max-width:100%;"></a></div></div> 
<br clear="both" />

<div class="relposts">
<div class="maincolumn_head">If you liked this post, you may also be interested in...</div>
<div class="maincolmod">
<ul>
<li><a href="/articles/20210515/11174146809/this-week-techdirt-history-may-9th-15th.shtml">This Week In Techdirt History: May 9th - 15th</a></li>
<li><a href="/articles/20210512/15435746782/content-moderation-case-study-youtubes-new-policy-nazi-content-results-removal-historical-education-videos-2019.shtml">Content Moderation Case Study: YouTube&#39;s New Policy On Nazi Content Results In Removal Of Historical And Education Videos (2019)</a></li>
<li><a href="/articles/20210508/11543446758/this-week-techdirt-history-may-2nd-8th.shtml">This Week In Techdirt History: May 2nd - 8th</a></li>
<li><a href="/articles/20210501/11212146717/this-week-techdirt-history-april-25th-may-1st.shtml">This Week In Techdirt History: April 25th - May 1st</a></li>
<li><a href="/articles/20210424/10595146672/this-week-techdirt-history-april-18th-24th.shtml">This Week In Techdirt History: April 18th - 24th</a></li>
</ul>
</div>
</div>

</div> <a name="comments"></a>
<div class="comments">
<a name="addyourcomment"></a>
<h3>Add Your Comment</h3>
<div id="comment-add">
<form class="comment-form" name="commentform" action="/comment_process.php" method="post">
<input type="hidden" name="nospam" value="yes" />
<input type="hidden" name="sid" value="20210522/11233746846" /><input type="hidden" name="replycid" value="0" />
<p>Have a Techdirt Account? <a href="/signin.php?nexturl=https%3A%2F%2Fwww.techdirt.com%2Farticles%2F20210522%2F11233746846%2Fthis-week-techdirt-history-may-16th-22nd.shtml"><b>Sign in now</b></a>. Want one? <a href="/register.php?nexturl=https%3A%2F%2Fwww.techdirt.com%2Farticles%2F20210522%2F11233746846%2Fthis-week-techdirt-history-may-16th-22nd.shtml"><b>Register here</b></a></p>
<input class="name" type="text" name="postername" value="" placeholder="name" /><br>
<input class="email" type="text" name="posteremail" value="" placeholder="email" /><br>
<p style="text-align:center;max-width:500px;"><input type="checkbox" name="emailsignup" value="yes" /> Subscribe to the <a href="https://listserv.techdirt.com/cgi-bin/dada/mail.cgi/list/techdirt/">Techdirt Daily</a> newsletter</p>
<input class="url" type="text" name="posterurl" maxlength="255" value="" placeholder="url" /><br>
<input class="subject" id="subject" type="text" name="postersubj" maxlength="64" value="" placeholder="subject" /><br>
<textarea name="postercomment" placeholder="comment" rows="10" style="display:none;">this is for spambots, do not use this</textarea>
<textarea class="comment" name="p1stercomment" placeholder="comment" rows="10"></textarea><br>
<p>
Comment Options:
<ul>
<li>
<input type="radio" name="mrkdwn" checked="checked" value='1' title="Format with markdown" /> Use <a href="http://commonmark.org/help/" target="_blank">markdown</a>.
<input type="radio" name="mrkdwn" value='0' title="Use plain text." /> Use plain text.
</li>
<li style="color:#888">Make this the
<input type="radio" name="callout" value="first" disabled="disabled" /> <i>First Word</i> or
<input type="radio" name="callout" value="last" disabled="disabled" /> <i>Last Word</i>.
<span style="white-space:nowrap"><input type="radio" name="callout" value="none" checked="checked" disabled="disabled" /> No thanks.</span>
<span style="white-space:nowrap"><small style="color:#333">(<a href="https://rtb.techdirt.com/products/credits/" style="font-weight:bold">get credits</a> or <a href="/signin.php?nexturl=https%3A%2F%2Fwww.techdirt.com%2Farticles%2F20210522%2F11233746846%2Fthis-week-techdirt-history-may-16th-22nd.shtml" style="font-weight:bold">sign in</a> to see balance)</small>&nbsp;&nbsp;&nbsp;<a title="what's this?" href="#" class="whatsthis help_cmntcallout">&nbsp;</a></span>
</li>
<li><input type="checkbox" name="cookie" /> Remember name/email/url (set a cookie)</li></ul>
</p>
<input type="submit" name="mode" value="Submit" class="td-button" /> <input type="submit" name="mode" value="Preview" class="td-button" />
</form></div>
</div>
<script type="text/javascript">
var fcnt = 0;
var icnt = 0;
</script>

<div class="storynav techdirt" style="margin-top:5px;">
<div class="storynav-prev">
<a title="previous Techdirt post: Makers Of &#39;Peaky Blinders&#39; Show Fail To Get Injunction Against Distillery For &#39;Peaky Blinders&#39; Whiskey" href="/articles/20210521/09172546838/makers-peaky-blinders-show-fail-to-get-injunction-against-distillery-peaky-blinders-whiskey.shtml" style="color:#777777;">Makers Of &#39;Peaky Blinders&#39; Show Fail To Get Injunction Against Distillery For &#39;Peaky Blinders&#39; Whiskey</a></div><div class="storynav-next nolink">
&nbsp;</div>
</div>
</div> 
</div> 
<div id="rightcolumn">
<div class="rightcolumn_head">Follow Techdirt</div>
<div class="rightcolumn_main" style="text-align:center;">
<div id="subscribe">
<a title="Follow us on Twitter" href="https://twitter.com/techdirt" target="_blank" class="follow twitter"></a>
<a title="Become a fan on Facebook" href="https://www.facebook.com/techdirt" target="_blank" class="follow facebook"></a>
<a title="Subscribe to our Newsletter" id="email_sub_tgl" href="https://news.techdirt.com/cgi-bin/dada/mail.cgi/list/tddaily" class="follow email"></a>
<a title="Subscribe to our RSS Feed" href="/techdirt_rss.xml" rel="nofollow" class="follow rss" onclick="(function(btn){var z=document.createElement('script');document.subtomeBtn=btn;z.src='https://www.subtome.com/load.js';document.body.appendChild(z);})(this);return false;" data-subtome-feeds="https://www.techdirt.com/techdirt_rss.xml"></a>
<a title="Subscribe to our Podcast" href="/podcast.xml" rel="nofollow" class="follow podcast"></a>
<div id="email_sub_form" class="hidden">
<h3>Techdirt Daily Newsletter</h3>
<form action="https://news.techdirt.com/cgi-bin/dada/mail.cgi" method="post" style="margin-top:3px;">
<input name="f" value="subscribe" type="hidden" />
<input name="email" placeholder="Enter Your Email Address" size="25" maxlength="1024" type="text" /><input value="Subscribe" type="submit" />
<input name="list" value="tddaily" type="hidden" />
</form>
</div>
</div>
</div><div class="rightcolumn_head">Insider Shop - Show Your Support!</div>
<div id="rtcol_1">
<a href="https://rtb.techdirt.com/"><img src="https://ii.techdirt.com/s/t/images/promo/insider-promo-gen-2-300x75.png" onclick="_gaq.push(['_trackEvent', 'Promo', 'Click', 'Insider Shop - RC Top']);" /></a><br />
</div><div class="rightcolumn_head">Essential Reading</div>
<div class="rightcolumn_main">
<div id="recreading">
<h4>The Techdirt Greenhouse</h4>
<p>Read the latest posts:</p>
<ul id="greenhouse-latest"><li><a href="/articles/20210105/08054145997/thats-wrap-techdirt-greenhouse-broadband-covid-era.shtml">That&#39;s A Wrap: Techdirt Greenhouse, Broadband In The Covid Era</a></li>
<li><a href="/articles/20210104/08093445992/could-digital-divide-unite-us.shtml">Could The Digital Divide Unite Us?</a></li>
<li><a href="/articles/20201223/07285845936/how-smart-software-ai-helped-networks-thrive-consumers-during-pandemic.shtml">How Smart Software And AI Helped Networks Thrive For Consumers During The Pandemic</a></li>
</ul>
<p style="text-align:right;"><a href="/blog/greenhouse">read all <span style="color:#f6aa4e;">&#187;</span></a></p>
</div>
</div>
<div class="rightcolumn_head">Techdirt Deals</div>
<div id="rtcol_3" class="ad">

<div data-sc-widget data-publisher-id="93" data-layout="vertical" data-categories="88,90,91" data-show-see-all="false" data-title-size="24" data-items-per-page="1" data-col-count="1"></div></div>
<div style="margin:0;padding:3px 5px 5px 5px;text-align:center;"><a href="/badad.php" style="font-style:italic;font-size:11px;" target="_blank" onclick="window.open('/badad.php', 'Report a bad ad on Techdirt', 'width=600,height=600,location=0,menubar=0,scrollbars=1,status=0,titlebar=1,toolbar=0', false);return(false);" rel="nofollow">Report this ad</a>&nbsp;&nbsp;|&nbsp;&nbsp;<a href="/preferences.php" style="font-style:italic;font-size:11px;">Hide Techdirt ads</a></div><link href="https://ii.techdirt.com/s/t/styles/styles_tdichat.css?v=3721-c395" rel="styleSheet" type="text/css" />
<div class="rightcolumn_head">Techdirt Insider Chat</div>
<div id="chatwrapper" class="shoutbox">
<br /><div id="chatbox">
<div id="chatmsgs">
&nbsp;
</div>
</div>
<div id="chatfooter">
<p style="text-align:center;padding:10px;padding-top:0;"><a href="https://rtb.techdirt.com/products/watercooler/" class="greenbutton">Join the Insider Chat</a></p>
</div>
</div>
<script type="text/javascript">
var iroot = 'https://ii.techdirt.com/s/t/i';
var chat_standalone = false;
var chat_id = 'aa07e073';
</script>
<script src="https://ii.techdirt.com/s/t/scripts/td-jq-ichat.js?v=3721-c395" type="text/javascript" language="javascript"></script>
<script type="text/javascript">
$j(document).ready(function() { loadChatPreview(); });
</script>
<div class="rightcolumn_head">Recent Stories</div>
<div class="rightcolumn_main">
<table>
<tr><td colspan="2"><h2 class="olderstuff"><a href="/blog/?d=22&m=5&y=2021">Saturday</a></h2></td></tr><tr><td class="olderstuff">12:00</td>
<td class="olderstuff"><a href="/articles/20210522/11233746846/this-week-techdirt-history-may-16th-22nd.shtml">This Week In Techdirt History: May 16th - 22nd</a> (0)</td></tr><tr><td colspan="2"><h2 class="olderstuff"><a href="/blog/?d=21&m=5&y=2021">Friday</a></h2></td></tr><tr><td class="olderstuff">19:39</td>
<td class="olderstuff"><a href="/articles/20210521/09172546838/makers-peaky-blinders-show-fail-to-get-injunction-against-distillery-peaky-blinders-whiskey.shtml">Makers Of &#39;Peaky Blinders&#39; Show Fail To Get Injunction Against Distillery For &#39;Peaky Blinders&#39; Whiskey</a> (14)</td></tr><tr><td class="olderstuff">15:42</td>
<td class="olderstuff"><a href="/articles/20210521/14114046843/content-moderation-case-study-kik-tries-to-get-abuse-under-control-2017.shtml">Content Moderation Case Study: Kik Tries To Get Abuse Under Control (2017)</a> (0)</td></tr><tr><td class="olderstuff">13:42</td>
<td class="olderstuff"><a href="/articles/20210512/23100646787/if-theres-defamatory-review-yelp-is-it-googles-job-to-hide-it.shtml">If There&#39;s A Defamatory Review On Yelp, Is It Google&#39;s Job To Hide It?</a> (24)</td></tr><tr><td class="olderstuff">12:15</td>
<td class="olderstuff"><a href="/articles/20210521/10411146841/how-camera-patent-was-used-to-sue-non-profits-cities-public-schools.shtml">How A Camera Patent Was Used To Sue Non-Profits, Cities, And Public Schools</a> (10)</td></tr><tr><td class="olderstuff">10:47</td>
<td class="olderstuff"><a href="/articles/20210520/16113946837/rachel-dolezals-copyright-follies-sues-cbs-copyright-infringement-case-that-wont-end-well.shtml">Rachel Dolezal&#39;s Copyright Follies: Sues CBS For Copyright Infringement In Case That Won&#39;t End Well</a> (10)</td></tr><tr><td class="olderstuff">10:42</td>
<td class="olderstuff"><a href="/articles/20210521/10323746839/daily-deal-2021-complete-aws-devops-engineer-bundle.shtml">Daily Deal: The 2021 Complete AWS DevOps Engineer Bundle</a> (0)</td></tr><tr><td class="olderstuff">09:28</td>
<td class="olderstuff"><a href="/articles/20210518/19183746825/california-city-drops-lawsuit-against-journalists-admits-it-failed-to-secure-files-supposedly-accessed-illegally.shtml">California City Drops Lawsuit Against Journalists; Admits It Failed To Secure Files Supposedly Accessed Illegally</a> (2)</td></tr><tr><td class="olderstuff">06:36</td>
<td class="olderstuff"><a href="/articles/20210520/09014446836/frontier-communications-sued-yet-again-lying-about-pathetic-broadband-speeds.shtml">Frontier Communications Sued Yet Again For Lying About Its Pathetic Broadband Speeds</a> (4)</td></tr><tr><td colspan="2"><h2 class="olderstuff"><a href="/blog/?d=20&m=5&y=2021">Thursday</a></h2></td></tr><tr><td class="olderstuff">20:10</td>
<td class="olderstuff"><a href="/articles/20210519/09565346829/unofficial-amiibo-guidebook-that-was-essentially-advertising-nintendo-products-gets-nintendod.shtml">Unofficial Amiibo Guidebook That Was Essentially Advertising Nintendo Products Gets Nintendo&#39;d</a> (23)</td></tr></table>
<h5><a href="/search.php?start=10&edition=techdirt&search=Search">More</a>&nbsp;<img alt="arrow" src="https://ii.techdirt.com/s/t/i/widget_arrow.gif" width="14" height="14" hspace="0" vspace="0" border="0" /></h5>
</div></div> 
</div>
<div id="bottom">
<div id="pagefoot">
<div class="ftrlinks">
<div>
<div class="ftrpanel">
<h1>Tools &amp; Services</h1>
<a href="https://www.twitter.com/techdirt/">Twitter</a><br />
<a href="https://www.facebook.com/techdirt">Facebook</a><br />
<a href="/techdirt_rss.xml">RSS</a><br />
<a href="/podcast.xml">Podcast</a><br />
<a href="/research.php">Research &amp; Reports</a><br />
</div>
<div class="ftrpanel">
<h1>Company</h1>
<a href="/about.php">About Us</a><br />
<a href="/adpolicies.php">Advertising Policies</a><br />
<a href="/privacy.php">Privacy</a><br />
</div>
</div>
<div>
<div class="ftrpanel">
<h1>Contact</h1>
<a href="/contact.php">Help &amp; Feedback</a><br />
<a href="/mediakit">Media Kit</a><br />
<a href="/contact.php?cat=Ads">Sponsor/Advertise</a><br />
<a href="/submitstory.php">Submit a Story</a><br />
</div>
<div class="ftrpanel">
<h1>More</h1>
<a href="https://copia.is">Copia Institute</a><br />
<a href="https://rtb.techdirt.com/">Insider Shop</a><br />
<a href="/pages/support.php">Support Techdirt</a><br />
</div>
</div>
</div>
<div class="ftrpanel ftrlogo">
<a href="/"><img src="https://ii.techdirt.com/s/t/i/td_logov140.png" /></a>
</div>
<br style="clear:both;" /><br />
<div style="text-align:center;">
Brought to you by <a href="http://www.floor64.com/">Floor64</a>
</div>
</div>
<br style="clear:both;" />
</div>
<style type="text/css">
#cookienotice {
  color:#aaa;
  background-color:#393838; 
  bottom:0%;
  font-size:120%;
  min-height:40px; 
  opacity:1;
  padding:15px;
  position:fixed; 
  width:100%; 
  text-align:center;
  z-index:999999;
}
#cookienotice a:link, #cookienotice a:visited {
  color:rgb(204, 227, 245);
}
#cookienotice a:link.td-button {
  color:#444;
}
</style>
<div id="cookienotice">
This site, like most other sites on the web, <a href="https://www.techdirt.com/articles/20200521/17152344550/yes-this-site-uses-cookies-because-nearly-all-sites-use-cookies-were-notifying-you-because-were-told-we-have-to.shtml">uses&nbsp;cookies</a>. For more information, see our <a href="https://www.techdirt.com/privacy.php">privacy&nbsp;policy</a>.
<a href="/ajax/json-set-user-preference.php?pn=hide_cookie_notice&pv=1&sc=max&next=ref" onclick="$j.cookie('hide_cookie_notice', 1, { expires: max, secure: 1, path: '/' });$j(this).parent().hide();return false;" class="td-button">Got it</a>
</div>
<div id="et_popup">
<a href="#" class="et_close">Close</a>
<p>Email This</p>
<div id="email_this">
<p style="color:#000000;">This feature is only available to registered users. <a href="/register.php">Register</a> or <a href="/signin.php">sign in</a> to use it.</p></div></div>
</body>
</html>