<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<meta id="tdviewport" name="viewport" content="width=device-width, initial-scale=1.0">
<meta name="news_keywords" content="drm, video games, denuvo">
<meta property="og:title" content="Denuvo Games Once Again Broken For Paying Customers Thanks To DRM Mishap" />
<meta property="og:description" content="It&#039;s been a while since we&#039;ve mentioned Denuvo, the once-vaunted anti-piracy video game DRM that subsequently became an industry punchline. Once touted as &quot;uncrackable&quot;, Denuvo went from there to becoming indeed crackable, then..." />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.techdirt.com/articles/20211109/09064247908/denuvo-games-once-again-broken-paying-customers-thanks-to-drm-mishap.shtml" />
<meta property="og:image" content="https://ii.techdirt.com/s/t/i/td_icon_300.png" />
<meta property="og:site_name" content="Techdirt." />
<meta property="fb:admins" content="589029834" />
<meta property="fb:app_id" content="207400865951050" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:site" content="@techdirt" />
<meta name="twitter:title" content="Denuvo Games Once Again Broken For Paying Customers Thanks To DRM Mishap" />
<meta name="twitter:description" content="It&#039;s been a while since we&#039;ve mentioned Denuvo, the once-vaunted anti-piracy video game DRM that subsequently became an..." />
<meta name="twitter:image" content="https://ii.techdirt.com/s/t/i/td_icon_300.png">
<title>Denuvo Games Once Again Broken For Paying Customers Thanks To DRM Mishap | Techdirt</title>
<link rel="canonical" type="text/html" href="https://www.techdirt.com/articles/20211109/09064247908/denuvo-games-once-again-broken-paying-customers-thanks-to-drm-mishap.shtml" />
<link rel="shortlink" type="text/html" href="https://tdrt.io/iIx" />
<link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="/comment_rss.php?sid=20211109/09064247908">
<link rel="stylesheet" href="https://use.fontawesome.com/releases/v5.15.4/css/all.css" integrity="sha384-DyZ88mC6Up2uqS4h/KRgHuoeGwBcD4Ng9SiP4dIRy0EXTlnuz47vAwmeGwVChigm" crossorigin="anonymous">
<link rel="styleSheet" type="text/css" href="https://ii.techdirt.com/s/t/styles/techdirt.css?v=3737-c396" />
<link rel="styleSheet" type="text/css" href="https://ii.techdirt.com/s/t/styles/comment_styles.css?v=3737-c396" />
<script src="https://cdnjs.cloudflare.com/ajax/libs/jquery/3.5.1/jquery.min.js" integrity="sha512-bLT0Qm9VnAYZDflyKcBaQ2gg0hSYNQrJ8RilYldYQ1FxQYoCLtUjuuRuZo+fjqhx/qtq/1itJ0C2ejDxltZVFg==" crossorigin="anonymous"></script><script src="https://ii.techdirt.com/s/t/scripts/techdirt.js?v=3737-c396" type="text/javascript" language="javascript"></script>
<script type="text/javascript" language="javascript">
var sid = '20211109/09064247908';
var base_path = 'https://www.techdirt.com';
</script>
<script src="https://ii.techdirt.com/s/t/scripts/td-jq-cmnt.js?v=3737-c396" type="text/javascript" language="javascript"></script>
<link href="https://fonts.googleapis.com/css?family=Raleway:400,600,600i,800" rel="stylesheet">
<script type="text/javascript">
var iroot = 'https://ii.techdirt.com/s/t/i';
</script>
<script type="text/javascript" src="https://s3.amazonaws.com/widgets.stackcommerce.com/js-deal-feed/0.1/widget.js"></script>
<link href="https://ii.techdirt.com/s/t/styles/greenhouse.css" rel="styleSheet" type="text/css" />
<meta name="monetization" content="$ilp.uphold.com/Jzw3EAY4mnYZ">
<script type="text/javascript">
  var _paq = window._paq = window._paq || [];
  _paq.push(['trackPageView']);
  _paq.push(['enableLinkTracking']);
  (function() {
    var u="//tomo.techdirt.com/matomo/";
    _paq.push(['setTrackerUrl', u+'matomo.php']);
    _paq.push(['setSiteId', '1']);
    var d=document, g=d.createElement('script'), s=d.getElementsByTagName('script')[0];
    g.type='text/javascript'; g.async=true; g.src=u+'matomo.js'; s.parentNode.insertBefore(g,s);
  })();
</script>
<script async defer data-domain="techdirt.com" src="https://tics.techdirt.com/js/index.js"></script>
</head>
<body class="edition-techdirt">
<div id="top">
<div id="header">
<div id="hdr_search">
<form action="/search-g.php" method="get">
<input class="searchq" type="text" size="16" name="q" placeholder="Search Techdirt" /><button class="icon"><i class="fa fa-search" style="margin:auto"></i></button>
</form>
</div>
<div id="hdr_logo">
<a href="/"><img class="hdr_title" src="https://ii.techdirt.com/s/t/i/logos/techdirt.svg" alt="Techdirt." border="0" /></a><br /></div>
<div id="hdr_nav">
<div id="hdr_nav_user">
<input type="checkbox" id="user-toggle">
<label for="user-toggle"><i class="fas fa-user" style="padding:5px;"></i></label>
<ul class="user_menu">
<li><a href="/signin.php?nexturl=https%3A%2F%2Fwww.techdirt.com%2Farticles%2F20211109%2F09064247908%2Fdenuvo-games-once-again-broken-paying-customers-thanks-to-drm-mishap.shtml">Sign In</a></li>
<li><a href="/register.php">Register</a></li>
<li><a href="/preferences.php">Preferences</a></li>
</ul>
</div>
<div id="hdr_nav_tabs">
<input type="checkbox" id="tabs-toggle">
<label for="tabs-toggle">Techdirt <i class="fas fa-bars" style="color:#eeeeee"></i></label>
<ul class="tabs_menu">
<li id="edition-tab-techdirt" class="tab_techdirt selected"><a href="/">Techdirt</a></li>
<li id="edition-tab-greenhouse" class="tab_greenhouse"><a href="/blog/greenhouse/">Greenhouse</a></li>
<li id="edition-tab-covid" class="tab_covid"><a href="/blog/covid/">Tech & COVID</a></li>
<li id="edition-tab-freespeech" class="tab_freespeech"><a href="/blog/freespeech/">Free Speech</a></li>
<li class="spacer">&nbsp;</li>
<li class="tab_deals"><a href="https://deals.techdirt.com">Deals</a></li>
<li class="tab_jobs"><a href="https://jobs.techdirt.com">Jobs</a></li>
<li class="tab_support"><a href="/pages/support.php">Support Techdirt</a></li>
</ul>
</div>
</div></div>
</div>
<div id="middle">
<div id="maincol-wrap">
<div id="maincolumn">
<div class="maincolumn_head">
</div> 
<div id="maincol_top">
<div style="background:#dddddd;padding:6px 7px;">
<a href="https://www.techdirt.com/blog/podcast/"><img src="https://ii.techdirt.com/s/t/i/podcast-title-small.png" style="display:block;float:left;margin-right:12px;" /></a>
<div style="width:calc(100% - 130px);max-width:556px;float:left;"><iframe width="100%" height="20" scrolling="no" frameborder="no" src="https://w.soundcloud.com/player/?url=https%3A//api.soundcloud.com/tracks/1156976869&amp;color=2665ad&amp;inverse=false&amp;auto_play=false&amp;show_user=true"></iframe></div><div style="clear:both;"></div>
</div></div><div class="storynav techdirt" style="margin-top:5px;">
<div class="storynav-prev">
<a title="previous Techdirt post: Content Moderation Case Study: Electric Truck Company Uses Copyright Claims To Hide Criticism (2020)" href="/articles/20211110/15341947918/content-moderation-case-study-electric-truck-company-uses-copyright-claims-to-hide-criticism-2020.shtml" style="color:#777777;">Content Moderation Case Study: Electric Truck Company Uses Copyright Claims To Hide Criticism (2020)</a></div><div class="storynav-next nolink">
&nbsp;</div>
</div>
<br clear="all" />

<div id="p76577" class="storyblock edition-techdirt">
<div class="storywrap">
<div class="story">
<div class="postbody">
<h1 class="posttitle">Denuvo Games Once Again Broken For Paying Customers Thanks To DRM Mishap</h1><div class="details">
<a href="/search.php?tid=uses&search=Search"><span class="topic_icon" style="background-position: -240px -204px;"></span></a>
<p><a href="/search.php?tid=uses&search=Search">(Mis)Uses of Technology</a></p>
</div>
<h3>from the <i>whoopsie</i> dept</h3><div class="byline"><span class="pub_date">Wed, Nov 10th 2021 8:12pm</span> &mdash;
<a href="/user/ronalddumsfeld">Timothy Geigner</a></div>
<p>
It's been a while since we've mentioned <a href="https://www.techdirt.com/blog/?tag=denuvo">Denuvo</a>, the once-vaunted anti-piracy video game DRM that subsequently became an industry punchline. Once touted as "<a href="https://www.techdirt.com/articles/20160826/07321835349/remember-when-cracking-groups-said-denuvo-would-end-game-piracy-yeah-didnt-happen.shtml">uncrackable</a>", Denuvo went from there to becoming indeed crackable, then crackable shortly after release of games, to then being crackable the <a href="https://www.techdirt.com/articles/20181206/13131241173/denuvo-protected-just-cause-4-cracked-day-suffering-shitty-reviews.shtml">same day</a>, to then being cracked in some cases <a href="https://www.techdirt.com/articles/20170929/09270138312/denuvo-game-cracked-mere-hours.shtml"><em>hours after</em></a> a game's release. As a result, plenty of publishers have taken to patching Denuvo <a href="https://www.techdirt.com/articles/20170530/14373037478/game-developer-just-wait-until-game-is-cracked-then-well-patch-denuvo-out-game-gets-cracked-immediately.shtml"><em>out of</em></a> their games, while Denuvo did a mini-pivot to create anti-cheat software for online games. While all that was going on, plenty of paying customers of games protected by Denuvo complained about various issues: authentication issues intermittently preventing the customer from playing the game they bought, <a href="https://www.techdirt.com/articles/20171101/09271938528/with-denuvo-broken-ubisoft-doubles-up-drm-assasins-creed-origin-tanking-everyones-computers.shtml">performance issues</a> that are linked back to how Denuvo runs and behaves, or Denuvo simply <a href="https://www.techdirt.com/articles/20171107/13073538568/drm-strikes-again-sonic-forces-just-plain-broken-thanks-to-denuvo.shtml">breaking games</a>.
</p>
<p>
In other words, Denuvo is a case study in real world DRM: no real protection from piracy, but plenty of headaches for paying customers. If that sounds like a recipe for disaster, well, <em>yeah</em>. But, it's an ongoing disaster, it appears. A whole bunch of PC video games <a href="https://torrentfreak.com/denuvo-protected-games-rendered-unplayable-after-domain-expires-211108/?utm_source=pocket_mylist">suddenly became unplayable this past week</a>, such as <em>Marvel's Guardians of the Galaxy</em>.
</p>
<blockquote>
<p>
<em>The problem seemed to appear after players updated the game, leading some to believe that code may have broken the game. However, as more and more complaints came in, another potential problem was identified. It was so simple as to be almost unthinkable but so devastating that it rendered games completely useless.</em>
</p>
</blockquote>
<p>
Once the same reports of games failing to load came in about several other titles, Twitter lit up about the topic. From there, the internet did its sleuthing thing and the one commonality uncovered was Denuvo DRM software. One Twitter denizen poked around and appears to have figured it out: someone at Denuvo forgot to renew a domain.
</p>
<blockquote>
<p>
<em>&ldquo;@PlanetZooGame @shadowofwargame your DRM provider has let their domain name lapse, and it&rsquo;s killed your game startup&hellip; along with multiple other games I imagine,&rdquo; he wrote.</em>
</p>
<p>
<em>Buckland identified the domain &lsquo;codefusion.technology&rsquo; as the culprit and offered a screenshot of its WHOIS records, which clearly shows that the domain expired on September 24, 2021, and had not been renewed. Following the failure to renew, the domain then went into a grace period but when that expired too, it appears to have been removed from DNS records. This meant that the domain would not resolve to an IP address, effectively breaking the system.</em>
</p>
</blockquote>
<p>
Now, that domain has now been renewed, so the problem for those gamers and games is fixed. But that cannot be the end of the story. For starters, TorrentFreak reached out to its regular contacts at Denuvo to get their take on all of this, but got undeliverable bounceback messages. Why that would occur is not currently known, but it's all just messy. In addition, the lack of communication or accountability from Denuvo or its parent company, Irdeto, is infuriating.
</p>
<blockquote>
<p>
<em>In the meantime, someone has now renewed the codefusion.technology domain, which appears to have solved players&rsquo; problems. It&rsquo;s now set to expire on September 24, 2022, meaning just a single year was added to the bank. Hopefully next year doesn&rsquo;t bring similar problems.</em>
</p>
</blockquote>
<p>
And by problems we apparently mean paying customers unable to play the games for which they paid, all because someone on Denuvo's side couldn't be bothered to keep its own domain up and running.
</p>
<p>
And that's the story of DRM. Again, anyone who pirated these games is not having a single problem. Only those that forked over cash to play are impacted. How that isn't the end of DRM adoption by the gaming companies is completely beyond me.
</p><div id="post_end">
<div id="post_end_plea_promo" name="post_end_plea"><img class="promo_close" src="https://ii.techdirt.com/s/t/i/topclose.png" alt="Hide this" title="Hide This" /><style>
div#post_end_plea_promo {background-color:#fefecb;margin:10px 0;padding:5px;}
</style>
<div style="color:#444;font-family:'Georgia','Times',serif;font-size:110%;font-style:italic;line-height:1.5;padding:20px;"><p>Thank you for reading this Techdirt post. With so many things competing for everyone’s attention these days, we really appreciate you giving us your time. We work hard every day to put quality content out there for our community.</p>
<p>Techdirt is one of the few remaining truly independent media outlets. We do not have a giant corporation behind us, and we rely heavily on our community to support us, in an age when advertisers are increasingly uninterested in sponsoring small, independent sites &mdash; especially a site like ours that is unwilling to pull punches in its reporting and analysis.</p>
<p>While other websites have resorted to paywalls, registration requirements, and increasingly annoying/intrusive advertising, we have always kept Techdirt open and available to anyone. But in order to continue doing so, <a href="https://www.techdirt.com/pages/support.php" style="font-weight:bold">we need your support</a>. We offer a variety of ways for our readers to support us, from direct donations to special subscriptions and cool merchandise &mdash; and every little bit helps. Thank you.<br></p>
<p style="margin-left:70%;padding:0;">&ndash;The Techdirt Team</p>
</div>
</div></div><p class="filed">Filed Under: <a href="/blog/?tag=drm">drm</a>, <a href="/blog/?tag=video+games">video games</a><br />Companies: <a href="/blog/?company=denuvo">denuvo</a></p></div>
</div>
</div> 
<div class="storyfooter">
<a name="share"></a><div class="storytools">
<div class="sharetools" style="float:right;">
<a class="share_pop" title="Short Link - right-click to copy" target="_blank" href="https://tdrt.io/iIx"><span class="share_button share_link"></span></a>
<a class="share_pop" title="Email this" target="_blank" href="https://www.techdirt.com/emailthis.php?et_url=https://www.techdirt.com/articles/20211109/09064247908/denuvo-games-once-again-broken-paying-customers-thanks-to-drm-mishap.shtml"><span class="share_button share_email"></span></a>
<a class="share_pop" title="Tweet" target="_blank" href="https://twitter.com/share?url=https%3A%2F%2Ftdrt.io%2FiIx&text=Denuvo+Games+Once+Again+Broken+For+Paying+Customers+Thanks+To+DRM+Mishap&via=Techdirt"><span class="share_button share_twitter"></span></a>
<a class="share_pop" title="Share on Facebook" target="_blank" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.techdirt.com%2Farticles%2F20211109%2F09064247908%2Fdenuvo-games-once-again-broken-paying-customers-thanks-to-drm-mishap.shtml&t=Denuvo+Games+Once+Again+Broken+For+Paying+Customers+Thanks+To+DRM+Mishap"><span class="share_button share_facebook"></span></a>
<a class="share_pop" title="Reddit This!" target="_blank" href="https://reddit.com/submit?url=https%3A%2F%2Fwww.techdirt.com%2Farticles%2F20211109%2F09064247908%2Fdenuvo-games-once-again-broken-paying-customers-thanks-to-drm-mishap.shtml&title=Denuvo+Games+Once+Again+Broken+For+Paying+Customers+Thanks+To+DRM+Mishap"><span class="share_button share_reddit"></span></a>
<a class="share_pop" title="Share on LinkedIn" target="_blank" href="https://www.linkedin.com/shareArticle?mini=true&ro=false&title=Denuvo+Games+Once+Again+Broken+For+Paying+Customers+Thanks+To+DRM+Mishap&url=https%3A%2F%2Fwww.techdirt.com%2Farticles%2F20211109%2F09064247908%2Fdenuvo-games-once-again-broken-paying-customers-thanks-to-drm-mishap.shtml"><span class="share_button share_linkedin"></span></a>
</div>
<div class="storylinks"><a href="https://www.techdirt.com/articles/20211109/09064247908/denuvo-games-once-again-broken-paying-customers-thanks-to-drm-mishap.shtml#comments">3 Comments</a> | <a href="https://www.techdirt.com/articles/20211109/09064247908/denuvo-games-once-again-broken-paying-customers-thanks-to-drm-mishap.shtml#addyourcomment">Leave a Comment</a></div>
</div>
</div> 
<br clear="both" />

<div class="relposts">
<div class="maincolumn_head">If you liked this post, you may also be interested in...</div>
<div class="maincolmod">
<ul>
<li><a href="/articles/20211105/11423647881/josh-hawley-war-men-is-driving-them-to-porn-video-games-things-many-men-like.shtml">Josh Hawley: The War On Men (?) Is Driving Them To Porn And Video Games (Things Many Men Like?)</a></li>
<li><a href="/articles/20211103/11075747870/what-if-era-video-game-mashups-is-about-to-begin.shtml">What If The Era Of Video Game Mashups Is About To Begin?</a></li>
<li><a href="/articles/20211028/11313047835/nintendo-killed-emulation-sites-then-released-garbage-n64-games-switch.shtml">Nintendo Killed Emulation Sites Then Released Garbage N64 Games For The Switch</a></li>
<li><a href="/articles/20210608/11271346954/denuvo-is-still-claiming-anti-piracy-business-even-as-games-continue-to-strip-out-denuvo-post-launch.shtml">Denuvo Is Still Claiming It&#39;s In The Anti-Piracy Business Even As Games Continue To Strip Out Denuvo Post-Launch</a></li>
<li><a href="/articles/20200521/11431944548/denuvos-anti-cheat-software-now-getting-ripped-games-record-speed-too.shtml">Denuvo&#39;s Anti-Cheat Software Now Getting Ripped From Games At Record Speed Too</a></li>
</ul>
</div>
</div>

</div> <a name="comments"></a>
<div class="comments">
<h2 style="margin-bottom:10px;">Reader Comments</h2>
<p style="float:right;position:relative;z-index:1;">Subscribe: <a href="/comment_rss.php?sid=20211109/09064247908" rel="nofollow">RSS</a></p>
<p style="float:left;">View by: <a href="/articles/20211109/09064247908/denuvo-games-once-again-broken-paying-customers-thanks-to-drm-mishap.shtml?threaded=false&sp=1#comments">Time</a> | <a href="/articles/20211109/09064247908/denuvo-games-once-again-broken-paying-customers-thanks-to-drm-mishap.shtml?threaded=true&sp=1#comments">Thread</a></p>
<br style="clear:both" />
<ul class="comments">
<li id="c24" class="cmt">
<div id="cc24">
<div class="comment-buttons" id="rc_24"><a rel="nofollow" href="/bounce/rate-comment.php?rc=ins_20211109/09064247908_24" value="0" id="ins_20211109/09064247908_24" class="rate_comment insightful-button"></a><a rel="nofollow" href="/bounce/rate-comment.php?rc=fun_20211109/09064247908_24" value="0" id="fun_20211109/09064247908_24" class="rate_comment funny-button"></a><a href="https://rtb.techdirt.com/products/credits/" class="fw-button off" target="_blank"></a><a href="https://rtb.techdirt.com/products/credits/" class="lw-button off" target="_blank"></a><a rel="nofollow" href="/bounce/rate-comment.php?rc=rpt_20211109/09064247908_24" value="0" id="rpt_20211109/09064247908_24" class="rate_comment report-button"></a></div>
<div class="commentname"><img class="cmnt-icon tds" src="https://ii.techdirt.com/s/t/i/user/15/85/u15853_30x0.jpg" width="30" alt="icon" /><div style="display:inline;"><b>Samuel Abram</b> (<a href="/user/ironcurtain">profile</a>), <i>10 Nov 2021 @ 6:25pm</i></div><br style="clear:both;" /></div>
<h3 class="commentsubject">FTFY</h3><div class="cbody"><blockquote>
<p>plenty of paying customers of games protected by Denuvo</p>
</blockquote>
<p>should be</p>
<blockquote>
<p>plenty of paying customers of games inhibited by Denuvo</p>
</blockquote>
<p>See, folks, this is why when I play games on PC, I go through GOG or itch.io first and Steam is dead last.</p></div><p class="cmt_ops">[&nbsp;<a class="cmtrp" href="/articles/20211109/09064247908/denuvo-games-once-again-broken-paying-customers-thanks-to-drm-mishap.shtml?cid=24#addyourcomment" cid="24" subject="FTFY" cid="24" title="Reply to this comment..." id="cmmt_link_24" rel="nofollow">reply to this</a>&nbsp;|&nbsp;<a href="/articles/20211109/09064247908/denuvo-games-once-again-broken-paying-customers-thanks-to-drm-mishap.shtml#c24">link to this</a>&nbsp;|&nbsp;<a href="/articles/20211109/09064247908/denuvo-games-once-again-broken-paying-customers-thanks-to-drm-mishap.shtml?threaded=false#c24">view in chronology</a>&nbsp;]
</p>
</div>
<li id="c40" class="cmt">
<div id="cc40">
<div class="comment-buttons" id="rc_40"><a rel="nofollow" href="/bounce/rate-comment.php?rc=ins_20211109/09064247908_40" value="0" id="ins_20211109/09064247908_40" class="rate_comment insightful-button"></a><a rel="nofollow" href="/bounce/rate-comment.php?rc=fun_20211109/09064247908_40" value="0" id="fun_20211109/09064247908_40" class="rate_comment funny-button"></a><a href="https://rtb.techdirt.com/products/credits/" class="fw-button off" target="_blank"></a><a href="https://rtb.techdirt.com/products/credits/" class="lw-button off" target="_blank"></a><a rel="nofollow" href="/bounce/rate-comment.php?rc=rpt_20211109/09064247908_40" value="0" id="rpt_20211109/09064247908_40" class="rate_comment report-button"></a></div>
<div class="commentname"><img class="cmnt-icon tds" src="https://ii.techdirt.com/s/t/i/user/no-icon.jpg" width="30" alt="icon" /><div style="display:inline;"><b>That One Guy</b> (<a href="/user/thatoneguy">profile</a>), <i>10 Nov 2021 @ 7:50pm</i></div><br style="clear:both;" /></div>
<h3 class="commentsubject">Pirates, as always, were completely unaffected</h3><div class="cbody"><p> <em> And that's the story of DRM. <strong> Again, anyone who pirated these games is not having a single problem. Only those that forked over cash to play are impacted.</strong> How that isn't the end of DRM adoption by the gaming companies is completely beyond me. </em> </p>
<p>This really needs to be hammered home any time a story like this pops up: <em> The only people DRM screws over are paying customers.</em> </p>
<p>If you are infecting your product with DRM you are not only punishing your <em> paying customers</em> and telling them that you don't trust them but you are giving them plenty of reasons to <em> stop paying you</em> since the pirated version of your product is almost certainly one that works <em> better</em>.</p></div><p class="cmt_ops">[&nbsp;<a class="cmtrp" href="/articles/20211109/09064247908/denuvo-games-once-again-broken-paying-customers-thanks-to-drm-mishap.shtml?cid=40#addyourcomment" cid="40" subject="Pirates, as always, were completely unaffected" cid="40" title="Reply to this comment..." id="cmmt_link_40" rel="nofollow">reply to this</a>&nbsp;|&nbsp;<a href="/articles/20211109/09064247908/denuvo-games-once-again-broken-paying-customers-thanks-to-drm-mishap.shtml#c40">link to this</a>&nbsp;|&nbsp;<a href="/articles/20211109/09064247908/denuvo-games-once-again-broken-paying-customers-thanks-to-drm-mishap.shtml?threaded=false#c40">view in chronology</a>&nbsp;]
</p>
</div>
<li id="c57" class="cmt">
<div id="cc57">
<div class="comment-buttons" id="rc_57"><a rel="nofollow" href="/bounce/rate-comment.php?rc=ins_20211109/09064247908_57" value="0" id="ins_20211109/09064247908_57" class="rate_comment insightful-button"></a><a rel="nofollow" href="/bounce/rate-comment.php?rc=fun_20211109/09064247908_57" value="0" id="fun_20211109/09064247908_57" class="rate_comment funny-button"></a><a href="https://rtb.techdirt.com/products/credits/" class="fw-button off" target="_blank"></a><a href="https://rtb.techdirt.com/products/credits/" class="lw-button off" target="_blank"></a><a rel="nofollow" href="/bounce/rate-comment.php?rc=rpt_20211109/09064247908_57" value="0" id="rpt_20211109/09064247908_57" class="rate_comment report-button"></a></div>
<div class="commentname"><img class="cmnt-icon" src="https://ii.techdirt.com/s/t/i/user/20/82/40/u208240_30x0.jpg" width="30" alt="icon" /><div style="display:inline;"><b>Stephen T. Stone</b> (<a href="/user/regularstone">profile</a>), <i>10 Nov 2021 @ 8:20pm</i></div><br style="clear:both;" /></div>
<h3 class="commentsubject">A relevant bit of copypasta:</h3><div class="cbody"><p> <strong> <em> DRM</em></strong> (initialism for “Digital Rights Management”) — <em> noun</em> — closed-source black box code that acts as the digital equivalent of an ankle bracelet tracking device for paying customers but does nothing to prevent copyright infringement carried out by non-paying customers; colloquially known as “Digital Restrictions Management”; <em> a stupid fucking idea</em></p></div><p class="cmt_ops">[&nbsp;<a class="cmtrp" href="/articles/20211109/09064247908/denuvo-games-once-again-broken-paying-customers-thanks-to-drm-mishap.shtml?cid=57#addyourcomment" cid="57" subject="A relevant bit of copypasta:" cid="57" title="Reply to this comment..." id="cmmt_link_57" rel="nofollow">reply to this</a>&nbsp;|&nbsp;<a href="/articles/20211109/09064247908/denuvo-games-once-again-broken-paying-customers-thanks-to-drm-mishap.shtml#c57">link to this</a>&nbsp;|&nbsp;<a href="/articles/20211109/09064247908/denuvo-games-once-again-broken-paying-customers-thanks-to-drm-mishap.shtml?threaded=false#c57">view in chronology</a>&nbsp;]
</p>
</div>
</ul>
<br /><a name="addyourcomment"></a>
<h3>Add Your Comment</h3>
<div id="comment-add">
<form class="comment-form" name="commentform" action="/comment_process.php" method="post">
<input type="hidden" name="nospam" value="yes" />
<input type="hidden" name="sid" value="20211109/09064247908" /><input type="hidden" name="replycid" value="0" />
<p>Have a Techdirt Account? <a href="/signin.php?nexturl=https%3A%2F%2Fwww.techdirt.com%2Farticles%2F20211109%2F09064247908%2Fdenuvo-games-once-again-broken-paying-customers-thanks-to-drm-mishap.shtml"><b>Sign in now</b></a>. Want one? <a href="/register.php?nexturl=https%3A%2F%2Fwww.techdirt.com%2Farticles%2F20211109%2F09064247908%2Fdenuvo-games-once-again-broken-paying-customers-thanks-to-drm-mishap.shtml"><b>Register here</b></a></p>
<input class="name" type="text" name="postername" value="" placeholder="name" /><br>
<input class="email" type="text" name="posteremail" value="" placeholder="email" /><br>
<p style="text-align:center;max-width:500px;"><input type="checkbox" name="emailsignup" value="yes" /> Subscribe to the <a href="https://listserv.techdirt.com/cgi-bin/dada/mail.cgi/list/techdirt/">Techdirt Daily</a> newsletter</p>
<input class="url" type="text" name="posterurl" maxlength="255" value="" placeholder="url" /><br>
<input class="subject" id="subject" type="text" name="postersubj" maxlength="64" value="" placeholder="subject" /><br>
<textarea name="postercomment" placeholder="comment" rows="10" style="display:none;">this is for spambots, do not use this</textarea>
<textarea class="comment" name="p1stercomment" placeholder="comment" rows="10"></textarea><br>
<p>
Comment Options:
<ul>
<li>
<input type="radio" name="mrkdwn" checked="checked" value='1' title="Format with markdown" /> Use <a href="http://commonmark.org/help/" target="_blank">markdown</a>.
<input type="radio" name="mrkdwn" value='0' title="Use plain text." /> Use plain text.
</li>
<li style="color:#888">Make this the
<input type="radio" name="callout" value="first" disabled="disabled" /> <i>First Word</i> or
<input type="radio" name="callout" value="last" disabled="disabled" /> <i>Last Word</i>.
<span style="white-space:nowrap"><input type="radio" name="callout" value="none" checked="checked" disabled="disabled" /> No thanks.</span>
<span style="white-space:nowrap"><small style="color:#333">(<a href="https://rtb.techdirt.com/products/credits/" style="font-weight:bold">get credits</a> or <a href="/signin.php?nexturl=https%3A%2F%2Fwww.techdirt.com%2Farticles%2F20211109%2F09064247908%2Fdenuvo-games-once-again-broken-paying-customers-thanks-to-drm-mishap.shtml" style="font-weight:bold">sign in</a> to see balance)</small>&nbsp;&nbsp;&nbsp;<a title="what's this?" href="#" class="whatsthis help_cmntcallout">&nbsp;</a></span>
</li>
<li><input type="checkbox" name="cookie" /> Remember name/email/url (set a cookie)</li></ul>
</p>
<input type="submit" name="mode" value="Submit" class="td-button" /> <input type="submit" name="mode" value="Preview" class="td-button" />
</form></div>

<div id="comment-reply" class="creply-form">
<a href="#" class="cmmt_close">Close</a>
<h3>Add A Reply</h3>
<form class="comment-form" name="commentform" action="/comment_process.php" method="post">
<input type="hidden" name="nospam" value="yes" />
<input type="hidden" name="sid" value="20211109/09064247908" /><input type="hidden" name="replycid" id="replycid" value="0" />
<p>Have a Techdirt Account? <a href="/signin.php?nexturl=https%3A%2F%2Fwww.techdirt.com%2Farticles%2F20211109%2F09064247908%2Fdenuvo-games-once-again-broken-paying-customers-thanks-to-drm-mishap.shtml"><b>Sign in now</b></a>. Want one? <a href="/register.php?nexturl=https%3A%2F%2Fwww.techdirt.com%2Farticles%2F20211109%2F09064247908%2Fdenuvo-games-once-again-broken-paying-customers-thanks-to-drm-mishap.shtml"><b>Register here</b></a></p>
<input class="name" type="text" name="postername" value="" placeholder="name" /><br>
<input class="email" type="text" name="posteremail" value="" placeholder="email" /><br>
<p style="text-align:center;max-width:500px;"><input type="checkbox" name="emailsignup" value="yes" /> Subscribe to the <a href="https://listserv.techdirt.com/cgi-bin/dada/mail.cgi/list/techdirt/">Techdirt Daily</a> newsletter</p>
<input class="url" type="text" name="posterurl" maxlength="255" value="" placeholder="url" /><br>
<input class="subject" id="replysubject" type="text" name="postersubj" maxlength="64" value="" placeholder="subject" /><br>
<textarea name="postercomment" placeholder="comment" rows="10" style="display:none;">this is for spambots, do not use this</textarea>
<textarea class="comment" name="p1stercomment" placeholder="comment" rows="10"></textarea><br>
<p>
Comment Options:
<ul>
<li>
<input type="radio" name="mrkdwn" checked="checked" value='1' title="Format with markdown" /> Use <a href="http://commonmark.org/help/" target="_blank">markdown</a>.
<input type="radio" name="mrkdwn" value='0' title="Use plain text." /> Use plain text.
</li>
<li style="color:#888">Make this the
<input type="radio" name="callout" value="first" disabled="disabled" /> <i>First Word</i> or
<input type="radio" name="callout" value="last" disabled="disabled" /> <i>Last Word</i>.
<span style="white-space:nowrap"><input type="radio" name="callout" value="none" checked="checked" disabled="disabled" /> No thanks.</span>
<span style="white-space:nowrap"><small style="color:#333">(<a href="https://rtb.techdirt.com/products/credits/" style="font-weight:bold">get credits</a> or <a href="/signin.php?nexturl=https%3A%2F%2Fwww.techdirt.com%2Farticles%2F20211109%2F09064247908%2Fdenuvo-games-once-again-broken-paying-customers-thanks-to-drm-mishap.shtml" style="font-weight:bold">sign in</a> to see balance)</small>&nbsp;&nbsp;&nbsp;<a title="what's this?" href="#" class="whatsthis help_cmntcallout">&nbsp;</a></span>
</li>
<li><input type="checkbox" name="cookie" /> Remember name/email/url (set a cookie)</li></ul>
</p>
<input type="submit" name="mode" value="Submit" class="td-button" /> <input type="submit" name="mode" value="Preview" class="td-button" />
</form></div>
</div>
<script type="text/javascript">
var fcnt = 0;
var icnt = 0;
</script>

<div class="storynav techdirt" style="margin-top:5px;">
<div class="storynav-prev">
<a title="previous Techdirt post: Content Moderation Case Study: Electric Truck Company Uses Copyright Claims To Hide Criticism (2020)" href="/articles/20211110/15341947918/content-moderation-case-study-electric-truck-company-uses-copyright-claims-to-hide-criticism-2020.shtml" style="color:#777777;">Content Moderation Case Study: Electric Truck Company Uses Copyright Claims To Hide Criticism (2020)</a></div><div class="storynav-next nolink">
&nbsp;</div>
</div>
</div> 
</div> 
<div id="rightcolumn">
<div class="rightcolumn_head">Follow Techdirt</div>
<div class="rightcolumn_main" style="text-align:center;">
<div id="subscribe">
<a title="Follow us on Twitter" href="https://twitter.com/techdirt" target="_blank" class="follow twitter"></a>
<a title="Become a fan on Facebook" href="https://www.facebook.com/techdirt" target="_blank" class="follow facebook"></a>
<a title="Subscribe to our Newsletter" id="email_sub_tgl" href="https://news.techdirt.com/cgi-bin/dada/mail.cgi/list/tddaily" class="follow email"></a>
<a title="Subscribe to our RSS Feed" href="/techdirt_rss.xml" rel="nofollow" class="follow rss" onclick="(function(btn){var z=document.createElement('script');document.subtomeBtn=btn;z.src='https://www.subtome.com/load.js';document.body.appendChild(z);})(this);return false;" data-subtome-feeds="https://www.techdirt.com/techdirt_rss.xml"></a>
<a title="Subscribe to our Podcast" href="/podcast.xml" rel="nofollow" class="follow podcast"></a>
<div id="email_sub_form" class="hidden">
<h3>Techdirt Daily Newsletter</h3>
<form action="https://news.techdirt.com/cgi-bin/dada/mail.cgi" method="post" style="margin-top:3px;">
<input name="f" value="subscribe" type="hidden" />
<input name="email" placeholder="Enter Your Email Address" size="25" maxlength="1024" type="text" /><input value="Subscribe" type="submit" />
<input name="list" value="tddaily" type="hidden" />
</form>
</div>
</div>
</div><div class="rightcolumn_head">Essential Reading</div>
<div class="rightcolumn_main">
<div id="recreading">
<h4>The Techdirt Greenhouse</h4>
<p>Read the latest posts:</p>
<ul id="greenhouse-latest"><li><a href="/articles/20211005/06472747699/winding-down-our-latest-greenhouse-panel-content-moderation-infrastructure-layer.shtml">Winding Down Our Latest Greenhouse Panel: Content Moderation At The Infrastructure Layer</a></li>
<li><a href="/articles/20211002/01062847677/does-internet-infrastructure-taxonomy-help-hurt.shtml">Does An Internet Infrastructure Taxonomy Help Or Hurt?</a></li>
<li><a href="/articles/20211005/11512347706/onlyfans-isnt-first-site-to-face-moderation-pressure-financial-intermediaries-it-wont-be-last.shtml">OnlyFans Isn&#39;t The First Site To Face Moderation Pressure From Financial Intermediaries, And It Won&#39;t Be The Last</a></li>
</ul>
<p style="text-align:right;"><a href="/blog/greenhouse">read all <span style="color:#f6aa4e;">&#187;</span></a></p>
<hr />
<h4>Trending Posts</h4>
<ul id="trending-posts">
<li class="ranked">
<a class="toppost-value" style="background-color:#ffaa33;border:#ffaa33;" href="/articles/20211020/17513847788/trump-announces-his-own-social-network-truth-social-which-says-it-can-kick-off-users-any-reason-already-is.shtml" title="">&nbsp;</a>
<a class="toppost-title" href="/articles/20211020/17513847788/trump-announces-his-own-social-network-truth-social-which-says-it-can-kick-off-users-any-reason-already-is.shtml" title="Trump Announces His Own Social Network, &#39;Truth Social,&#39; Which Says It Can Kick Off Users For Any Reason (And Already Is)">Trump Announces His Own Social Network, &#39;Truth Social,&#39; Which Says It Can Kick Off Users For Any Reason (And Already Is)</a>
</li>
<li class="ranked">
<a class="toppost-value" style="background-color:#ffca44;border:#ffca44;" href="/articles/20211029/17155547844/document-freed-foia-shows-how-much-data-fbi-can-obtain-cellphone-service-providers.shtml" title="">&nbsp;</a>
<a class="toppost-title" href="/articles/20211029/17155547844/document-freed-foia-shows-how-much-data-fbi-can-obtain-cellphone-service-providers.shtml" title="Document Freed By FOIA Shows How Much Data The FBI Can Obtain From Cellphone Service Providers">Document Freed By FOIA Shows How Much Data The FBI Can Obtain From Cellphone Service Providers</a>
</li>
<li class="ranked">
<a class="toppost-value" style="background-color:#ffea55;border:#ffea55;" href="/articles/20211030/21510147853/austin-homeowners-association-pitches-to-help-cops-kill-guy-over-uncut-grass.shtml" title="">&nbsp;</a>
<a class="toppost-title" href="/articles/20211030/21510147853/austin-homeowners-association-pitches-to-help-cops-kill-guy-over-uncut-grass.shtml" title="Austin Homeowners Association Pitches In To Help Cops Kill A Guy Over Uncut Grass">Austin Homeowners Association Pitches In To Help Cops Kill A Guy Over Uncut Grass</a>
</li>
</ul>
</div>
</div>
<div class="rightcolumn_head">Techdirt Deals</div>
<div id="rtcol_3" class="ad">

<div data-sc-widget data-publisher-id="93" data-tracking="false" data-layout="vertical" data-categories="88,90,91" data-show-see-all="false" data-title-size="24" data-items-per-page="1" data-col-count="1"></div></div>
<div style="margin:0;padding:3px 5px 5px 5px;text-align:center;"><a href="/badad.php" style="font-style:italic;font-size:11px;" target="_blank" onclick="window.open('/badad.php', 'Report a bad ad on Techdirt', 'width=600,height=600,location=0,menubar=0,scrollbars=1,status=0,titlebar=1,toolbar=0', false);return(false);" rel="nofollow">Report this ad</a>&nbsp;&nbsp;|&nbsp;&nbsp;<a href="/preferences.php" style="font-style:italic;font-size:11px;">Hide Techdirt ads</a></div><link rel="preconnect" href="https://fonts.googleapis.com">
<link rel="preconnect" href="https://fonts.gstatic.com" crossorigin>
<link href="https://fonts.googleapis.com/css2?family=Open+Sans:wght@400;600;700&display=swap" rel="stylesheet">
<link href="https://ii.techdirt.com/s/t/styles/td-insider-discord.css?v=3737-c396" rel="styleSheet" type="text/css" />
<div class="rightcolumn_head">Techdirt Insider Discord <i class="fab fa-discord"></i></div>
<div id="chat-wrap">
<div id="chat-header"><style type="text/css">
  #chat-header>p.intro {
    background: #0b63a3;
    color: #ffffff;
    font-size: 110%;
    font-style: italic;
    font-weight: bold;
    margin: 2px;
    padding: 0.5rem;
  }
</style>
<p class="intro">The latest chatter on the Techdirt Insider Discord channel...</p></div><div class="loading-msg chat-center-xy">Loading...</div>
<div class="notification chat-center-xy hidden"></div>
<div id="chat-msgs">
</div>
<div id="chat-footer">
<p><a href="https://rtb.techdirt.com/products/watercooler/" target="_blank" class="chat-cta-btn">Become an Insider!</a></p>
</div>
</div>
<script src="https://cdn.socket.io/4.1.2/socket.io.min.js" integrity="sha384-toS6mmwu70G0fw54EGlWWeA4z3dyJ+dlXBtSURSKN4vyRFOcxd3Bzjj/AoOwY+Rg" crossorigin="anonymous"></script>
<script src="https://ii.techdirt.com/s/t/scripts/td-insider-discord.js"></script><div class="rightcolumn_head">Recent Stories</div>
<div class="rightcolumn_main">
<table>
<tr><td colspan="2"><h2 class="olderstuff"><a href="/blog/?d=10&m=11&y=2021">Wednesday</a></h2></td></tr><tr><td class="olderstuff">20:12</td>
<td class="olderstuff"><a href="/articles/20211109/09064247908/denuvo-games-once-again-broken-paying-customers-thanks-to-drm-mishap.shtml">Denuvo Games Once Again Broken For Paying Customers Thanks To DRM Mishap</a> (3)</td></tr><tr><td class="olderstuff">15:41</td>
<td class="olderstuff"><a href="/articles/20211110/15341947918/content-moderation-case-study-electric-truck-company-uses-copyright-claims-to-hide-criticism-2020.shtml">Content Moderation Case Study: Electric Truck Company Uses Copyright Claims To Hide Criticism (2020)</a> (2)</td></tr><tr><td class="olderstuff">13:36</td>
<td class="olderstuff"><a href="/articles/20211108/06354047897/apple-faces-yet-more-right-to-repair-backlash-over-iphone-13-screen.shtml">Apple Faces Yet More &#39;Right To Repair&#39; Backlash Over iPhone 13 Screen</a> (10)</td></tr><tr><td class="olderstuff">12:00</td>
<td class="olderstuff"><a href="/articles/20211110/11331647915/missouri-admits-it-fucked-up-exposing-teacher-data-offers-apology-to-teachers-not-to-journalists-it-falsely-accused-hacking.shtml">Missouri Admits It Fucked Up In Exposing Teacher Data, Offers Apology To Teachers -- But Not To Journalists It Falsely Accused Of Hacking</a> (16)</td></tr><tr><td class="olderstuff">10:50</td>
<td class="olderstuff"><a href="/articles/20211107/10412047891/seven-years-after-discovering-rogue-stingray-devices-dc-federal-govt-still-doesnt-have-any-idea-what-to-do-about-it.shtml">Seven Years After Discovering Rogue Stingray Devices In DC, The Federal Gov&#39;t Still Doesn&#39;t Have Any Idea What To Do About It</a> (16)</td></tr><tr><td class="olderstuff">10:45</td>
<td class="olderstuff"><a href="/articles/20211110/10074247914/daily-deal-stackskills-unlimited.shtml">Daily Deal: StackSkills Unlimited</a> (0)</td></tr><tr><td class="olderstuff">09:40</td>
<td class="olderstuff"><a href="/articles/20211109/10460447910/latest-version-congresss-anti-algorithm-bill-is-based-two-separate-debunked-myths-misunderstanding-how-things-work.shtml">The Latest Version Of Congress&#39;s Anti-Algorithm Bill Is Based On Two Separate Debunked Myths &#038; A Misunderstanding Of How Things Work</a> (33)</td></tr><tr><td class="olderstuff">07:59</td>
<td class="olderstuff"><a href="/articles/20211108/08353547899/infrastructure-bill-is-great-broadband-still-ignores-real-problem-monopolies-corruption.shtml">Infrastructure Bill Is Great For Broadband, But Still Ignores The Real Problem (Monopolies & Corruption)</a> (11)</td></tr><tr><td colspan="2"><h2 class="olderstuff"><a href="/blog/?d=9&m=11&y=2021">Tuesday</a></h2></td></tr><tr><td class="olderstuff">20:10</td>
<td class="olderstuff"><a href="/articles/20211105/12483447882/gasp-youtube-shutters-account-person-committing-dmca-takedown-fraud.shtml">Gasp! YouTube Shutters Account For Person Committing DMCA Takedown Fraud!</a> (11)</td></tr><tr><td class="olderstuff">15:47</td>
<td class="olderstuff"><a href="/articles/20211030/17350447851/students-have-rights-court-dumps-evidence-after-cops-rely-month-old-anonymous-tip-to-search-minor.shtml">Students Have Rights: Court Dumps Evidence After Cops Rely On A Month-Old Anonymous Tip To Search A Minor</a> (15)</td></tr></table>
<h5><a href="/search.php?start=10&edition=techdirt&search=Search">More</a>&nbsp;<img alt="arrow" src="https://ii.techdirt.com/s/t/i/widget_arrow.gif" width="14" height="14" hspace="0" vspace="0" border="0" /></h5>
</div></div> 
</div>
<div id="bottom">
<div id="pagefoot">
<div class="ftrlinks">
<div>
<div class="ftrpanel">
<h1>Tools &amp; Services</h1>
<a href="https://www.twitter.com/techdirt/">Twitter</a><br />
<a href="https://www.facebook.com/techdirt">Facebook</a><br />
<a href="/techdirt_rss.xml">RSS</a><br />
<a href="/podcast.xml">Podcast</a><br />
<a href="/research.php">Research &amp; Reports</a><br />
</div>
<div class="ftrpanel">
<h1>Company</h1>
<a href="/about.php">About Us</a><br />
<a href="/adpolicies.php">Advertising Policies</a><br />
<a href="/privacy.php">Privacy</a><br />
</div>
</div>
<div>
<div class="ftrpanel">
<h1>Contact</h1>
<a href="/contact.php">Help &amp; Feedback</a><br />
<a href="/mediakit">Media Kit</a><br />
<a href="/contact.php?cat=Ads">Sponsor/Advertise</a><br />
<a href="/submitstory.php">Submit a Story</a><br />
</div>
<div class="ftrpanel">
<h1>More</h1>
<a href="https://copia.is">Copia Institute</a><br />
<a href="https://rtb.techdirt.com/">Insider Shop</a><br />
<a href="/pages/support.php">Support Techdirt</a><br />
</div>
</div>
</div>
<div class="ftrpanel ftrlogo">
<a href="/"><img src="https://ii.techdirt.com/s/t/i/td_logov140.png" /></a>
</div>
<br style="clear:both;" /><br />
<div style="text-align:center;">
Brought to you by <a href="http://www.floor64.com/">Floor64</a>
</div>
</div>
<br style="clear:both;" />
</div>
<style type="text/css">
#cookienotice {
  color:#aaa;
  background-color:#393838; 
  bottom:0%;
  font-size:120%;
  min-height:40px; 
  opacity:1;
  padding:15px;
  position:fixed; 
  width:100%; 
  text-align:center;
  z-index:999999;
}
#cookienotice a:link, #cookienotice a:visited {
  color:rgb(204, 227, 245);
}
#cookienotice a:link.td-button {
  color:#444;
}
</style>
<div id="cookienotice">
This site, like most other sites on the web, <a href="https://www.techdirt.com/articles/20200521/17152344550/yes-this-site-uses-cookies-because-nearly-all-sites-use-cookies-were-notifying-you-because-were-told-we-have-to.shtml">uses&nbsp;cookies</a>. For more information, see our <a href="https://www.techdirt.com/privacy.php">privacy&nbsp;policy</a>.
<a href="/ajax/json-set-user-preference.php?pn=hide_cookie_notice&pv=1&sc=max&next=ref" onclick="$j.cookie('hide_cookie_notice', 1, { expires: max, secure: 1, path: '/' });$j(this).parent().hide();return false;" class="td-button">Got it</a>
</div>
<div id="et_popup">
<a href="#" class="et_close">Close</a>
<p>Email This</p>
<div id="email_this">
<p style="color:#000000;">This feature is only available to registered users. <a href="/register.php">Register</a> or <a href="/signin.php">sign in</a> to use it.</p></div></div>
</body>
</html>