Clearwire's Non-WiMax Now Non-Useful: Blocks VoIP, Streaming Media

from the wonderful dept

Craig McCaw's Clearwire wireless outfit has received plenty of attention -- mainly for being run by Craig McCaw. Late last year, Intel had to pay Clearwire to convince them to use WiMax (which, still doesn't actually exist) as the core of their wireless offering, as WiMax was proving to be increasingly less than the hype would have you believe. Earlier this month, Bell Canada made a surprise announcement, saying they would provide VoIP for Clearwire in the US -- giving the Canadian telco a way to enter the US market. Still, it appears the folks at Clearwire haven't been paying attention to the whole "network neutrality" debate or the fact that an ISP has been fined for blocking Vonage. Instead, Clearwire proudly states that they will block any application they don't like -- including non-Bell Canada VoIP and any streaming audio or video offering. In other words, Clearwire's wireless broadband is becoming close to useless, because they want to control what you can and can't do over it. They claim they need to do this "to ensure network performance reliability," but can't explain how it's okay for them to offer VoIP, but Vonage must be blocked. More importantly, if Clearwire is saying they can't have a stable network when people are doing VoIP or streaming media, it certainly raises a lot of questions about the quality of WiMax.

Reader Comments

Subscribe: RSS

View by: Time | Thread


  1. identicon
    Anonymous Coward, 22 Jun 2009 @ 10:51pm

    BOTTOM LINE: Coverage problems all over Portland and in building. If you can get a connection it is fast.

    I was excited to buy Clear to get the WiMax fast internet. I bought everything: the home modem., USB mobile, and Clear Spot (mobile wireless).

    When I got home (Lake Oswego near downtown), the Home modem and mobile wireless did not work. The signal was too weak to connect. I called support and they had me check the modem throughout the inside of the house. Nothing. So I got a long extensions cord and checked outside the house in all directions. Nothing.

    So I drove around Portland from Tigard to Vancouver on I-5 and also drove east to west. In my car I had the home modem and mobile USB on. I found huge coverage issues. Sometimes from block to block I would lose signal.

    Downtown when I was outside, I got coverage. But then I walked into a number of building - no coverage. I need this mobile internet to do presentations. There is no way it is reliable enough - not even close. So I returned everything within 6 days (which was a hassle and required a one hour phone call).

    I have to say when I could get a connection it was very fast (6 MB down).

Add Your Comment

Have a Techdirt Account? Sign in now. Want one? Register here



Subscribe to the Techdirt Daily newsletter




Comment Options:

  • Use markdown. Use plain text.
  • Remember name/email/url (set a cookie)

Follow Techdirt
Insider Shop - Show Your Support!

Advertisement
Report this ad  |  Hide Techdirt ads
Essential Reading
Techdirt Deals
Report this ad  |  Hide Techdirt ads
Techdirt Insider Chat
Advertisement
Report this ad  |  Hide Techdirt ads
Recent Stories
Advertisement
Report this ad  |  Hide Techdirt ads

Close

Email This

This feature is only available to registered users. Register or sign in to use it.